summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-12-12 08:51:58 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-12 08:51:58 +0100
commitcc37a07f289f56a81195933810af705d77e95ee4 (patch)
tree6e099b2aaef7cd754a8b357a2abd419c53e356ad
parentb7a2358f0babe29219f3e2956eae53603b4a7f2c (diff)
zlib: really fix install for static only builds
Commit ab2f5567c1 (cleanup, fix install for static only build) forgot to add the patch for static only builds, even though the commit message mentioned it. Thanks to Mike for noticing. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES2
-rw-r--r--package/zlib/zlib-1.2.5-fix-static-install.patch24
2 files changed, 25 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 399dba2f1..7d79c27ff 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,7 @@
compilation, and cache is stored in ~/.buildroot-ccache.
Updated/fixed packages: busybox, cloop, libconfig, m4,
- openssh, openssl, qt, usbutils, xz
+ openssh, openssl, qt, usbutils, xz, zlib
New packages: dhrystone, lsuio, rsh-redone, whetstone
diff --git a/package/zlib/zlib-1.2.5-fix-static-install.patch b/package/zlib/zlib-1.2.5-fix-static-install.patch
new file mode 100644
index 000000000..0a885f742
--- /dev/null
+++ b/package/zlib/zlib-1.2.5-fix-static-install.patch
@@ -0,0 +1,24 @@
+[PATCH] fix make install for static builds
+
+Only try to install shared lib if we've built one.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile.in | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+Index: zlib-1.2.5/Makefile.in
+===================================================================
+--- zlib-1.2.5.orig/Makefile.in
++++ zlib-1.2.5/Makefile.in
+@@ -168,7 +168,9 @@ install-libs: $(LIBS)
+ -@if [ ! -d $(DESTDIR)$(man3dir) ]; then mkdir -p $(DESTDIR)$(man3dir); fi
+ -@if [ ! -d $(DESTDIR)$(pkgconfigdir) ]; then mkdir -p $(DESTDIR)$(pkgconfigdir); fi
+ cp $(STATICLIB) $(DESTDIR)$(libdir)
+- cp $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir)
++ if test "$(SHAREDLIBV)" -a -f $(SHAREDLIBV); then \
++ cp $(SHAREDLIBV) $(DESTDIR)$(sharedlibdir); \
++ fi
+ cd $(DESTDIR)$(libdir); chmod u=rw,go=r $(STATICLIB)
+ -@(cd $(DESTDIR)$(libdir); $(RANLIB) libz.a || true) >/dev/null 2>&1
+ -@cd $(DESTDIR)$(sharedlibdir); if test "$(SHAREDLIBV)" -a -f $(SHAREDLIBV); then \