summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-06 14:37:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-06 14:37:22 +0200
commitdd0d0f96d8e7a4b1feb2374c789892eec4386100 (patch)
tree0a6a335359b936693b15c2baca83823bddd3176a
parent113d5d1adb66b6af195b456988c1fea43b661934 (diff)
dropbear: add option to disable reverse DNS lookups
Add option to disable reverse DNS lookups on client connection, as connections otherwise stall until DNS times out in configurations without working reverse DNS. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES2
-rw-r--r--package/dropbear/Config.in8
-rw-r--r--package/dropbear/dropbear.mk4
3 files changed, 13 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 03bc5f4f4..394bb5ff2 100644
--- a/CHANGES
+++ b/CHANGES
@@ -5,7 +5,7 @@
Kconfig infrastructure rebased against 2.6.36-rc1, bringing
misc fixes + nconfig and savedefconfig targets.
- Updated/fixed packages: busybox
+ Updated/fixed packages: busybox, dropbear
2010.08: Released August 31th, 2010:
diff --git a/package/dropbear/Config.in b/package/dropbear/Config.in
index 20469f8b2..e47ba4545 100644
--- a/package/dropbear/Config.in
+++ b/package/dropbear/Config.in
@@ -5,3 +5,11 @@ config BR2_PACKAGE_DROPBEAR
A small SSH 2 server designed for small memory environments.
http://matt.ucc.asn.au/dropbear/dropbear.html
+
+config BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS
+ bool "disable reverse DNS lookups"
+ depends on BR2_PACKAGE_DROPBEAR
+ help
+ Disable reverse DNS lookups on connection. This can be handy
+ on systems without working DNS, as connections otherwise
+ stall until DNS times out.
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index c73525b04..ec678d7e9 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -21,6 +21,10 @@ $(eval $(call AUTOTARGETS,package,dropbear))
$(DROPBEAR_HOOK_POST_EXTRACT):
$(SED) 's,^#define XAUTH_COMMAND.*/xauth,#define XAUTH_COMMAND "/usr/bin/xauth,g' $(DROPBEAR_DIR)/options.h
+ifeq ($(BR2_PACKAGE_DROPBEAR_DISABLE_REVERSEDNS),y)
+ $(SED) 's,^#define DO_HOST_LOOKUP.*,/* #define DO_HOST_LOOKUP */,' \
+ $(DROPBEAR_DIR)/options.h
+endif
touch $@
$(DROPBEAR_TARGET_INSTALL_TARGET):