summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-10 23:50:45 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-11 21:10:35 +0200
commit04ba0089a672863e333a2de6b19d9b77fd0b26c1 (patch)
treeefa1683cacdda6ad37f61b4acf2275f734e38dff
parent423399ba56d520410a8d3a0525c26ddd9fba11d4 (diff)
Get rid of the OPTIMIZE_FOR_CPU variable
This variable, together with the FIXME comment, has been added has part of Eric Andersen's « Major buildroot facelift, step one » commit that occured in October 2004. Since then, no real usage has been made of OPTIMIZE_FOR_CPU, and the initial intention has probably been lost in the memories of the implementors. Therefore, get rid of the variable, and just use $(ARCH) at the two locations the variable was used. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Makefile.in4
-rw-r--r--toolchain/Makefile.in3
2 files changed, 2 insertions, 5 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 43ff2ddad..983caf38e 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -109,8 +109,8 @@ TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
# Quotes are needed for spaces et al in path components.
TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
-GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
-REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
+GNU_TARGET_NAME=$(ARCH)-linux
+REAL_GNU_TARGET_NAME=$(ARCH)$(GNU_TARGET_SUFFIX)
TARGET_CROSS=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
KERNEL_CROSS=$(TARGET_CROSS)
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
diff --git a/toolchain/Makefile.in b/toolchain/Makefile.in
index 91aa17af6..57d84a3e7 100644
--- a/toolchain/Makefile.in
+++ b/toolchain/Makefile.in
@@ -30,8 +30,5 @@ BR2_SYSROOT=# nothing
BR2_ISYSROOT=#nothing
endif
-# FIXME -- this is temporary
-OPTIMIZE_FOR_CPU=$(ARCH)
-
# gcc has a bunch of needed stuff....
include toolchain/gcc/Makefile.in