summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2009-10-07 22:08:31 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-07 22:33:52 +0200
commit0bc7a43ff3297ecff969fe9f865ff34e3b88a39e (patch)
treead561bb7ee5d780295087f1c7e8d5750e34ecc0e
parent10eaccc2332b0366b10fbe7f0c4dc6c12332e130 (diff)
remove BR2_FPU_SUFFIX
hard/softfloat is just one of the many config options, and it only clutters the filenames. Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--Config.in7
-rw-r--r--package/Makefile.in10
2 files changed, 2 insertions, 15 deletions
diff --git a/Config.in b/Config.in
index cc83a6aff..86e50ac97 100644
--- a/Config.in
+++ b/Config.in
@@ -99,13 +99,6 @@ config BR2_STAGING_DIR
Most people will leave this set to the default value of
"$(BASE_DIR)/staging".
-config BR2_FPU_SUFFIX
- bool "Add '_nofpu' suffix for softfloat toolchains"
- help
- If the toolchain is configured to use softfloat, then
- the "_nofpu" suffix will be added to the toolchain build
- directory name and to any rootfs image name
-
config BR2_GNU_BUILD_SUFFIX
string "GNU build hostname suffix"
default "pc-linux-gnu"
diff --git a/package/Makefile.in b/package/Makefile.in
index fa7c7409f..ccd7480e2 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -105,18 +105,12 @@ XXXX=xxxx
ROOTFS_SUFFIX:=-$(BR2_ROOTFS_SUFFIX)
endif
-ifeq ($(call qstrip,$(BR2_FPU_SUFFIX)),y)
-COND_ARCH_FPU_SUFFIX:=$(ARCH_FPU_SUFFIX)
-else
-COND_ARCH_FPU_SUFFIX:=
-endif
-
ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
# Quotes are needed for spaces et al in path components.
TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
-IMAGE:=$(BINARIES_DIR)/$(BR2_ROOTFS_PREFIX).$(ARCH)$(COND_ARCH_FPU_SUFFIX)$(ROOTFS_SUFFIX)
+IMAGE:=$(BINARIES_DIR)/$(BR2_ROOTFS_PREFIX).$(ARCH)$(ROOTFS_SUFFIX)
GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
TARGET_CROSS=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
@@ -127,7 +121,7 @@ TOOLCHAIN_EXTERNAL_PATH:=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PATH))
TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
TARGET_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(TOOLCHAIN_DIR)/bin:$(TOOLCHAIN_EXTERNAL_PATH)/bin:$(PATH)"
#IMAGE:=$(BINARIES_DIR)/$(BR2_ROOTFS_PREFIX).$(TOOLCHAIN_EXTERNAL_PREFIX)$(ROOTFS_SUFFIX)
-IMAGE:=$(BINARIES_DIR)/$(BR2_ROOTFS_PREFIX).$(ARCH)$(COND_ARCH_FPU_SUFFIX)$(ROOTFS_SUFFIX)
+IMAGE:=$(BINARIES_DIR)/$(BR2_ROOTFS_PREFIX).$(ARCH)$(ROOTFS_SUFFIX)
REAL_GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)
GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)