summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-18 15:54:55 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-18 16:02:51 +0100
commit1b07928aa647074f790a01f0302f241391b5c923 (patch)
tree8f7f552fea831f6482ca255f501e82650cfc3d22
parent38faeafab7cf0272093ad996225b2f7dbdaa2d42 (diff)
Only derrive HOST_FOO_DEPENDENCIES from FOO_DEPENDENCIES if not set, not nonempty
In make, ifndef VAR means if 'VAR is not set to the empty string', and NOT 'VAR is not defined', which meant that you couldn't specify empty FOO_HOST_DEPENDENCIES. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/Makefile.autotools.in7
-rw-r--r--package/Makefile.package.in6
2 files changed, 3 insertions, 10 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 495a07580..0f9b2c60f 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -203,12 +203,9 @@ endef
# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
# away from the non-host rule
-ifndef $(2)_DEPENDENCIES
- ifdef $(3)_DEPENDENCIES
- $(2)_DEPENDENCIES = $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
- endif
-endif
+
ifeq ($$($(2)_AUTORECONF),YES)
$(2)_PRE_CONFIGURE_HOOKS += AUTORECONF_HOOK
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index a27804b81..e57bfed1b 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -542,11 +542,7 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-ifndef $(2)_DEPENDENCIES
- ifdef $(3)_DEPENDENCIES
- $(2)_DEPENDENCIES = $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
- endif
-endif
+$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO