summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-07-27 08:54:01 +0000
committerEric Andersen <andersen@codepoet.org>2002-07-27 08:54:01 +0000
commit3aff447b6114ae52c4622e208256da2220e13f0e (patch)
tree2943ad291758c7c92355a15853e80b85b08354e8
parentd30b9abaeb3ca378fb4d62c096522327e2e5dde5 (diff)
Update valgrind, make it compile
-Erik
-rw-r--r--make/valgrind.mk5
-rw-r--r--sources/valgrind.patch18
2 files changed, 21 insertions, 2 deletions
diff --git a/make/valgrind.mk b/make/valgrind.mk
index b65675a33..13230d996 100644
--- a/make/valgrind.mk
+++ b/make/valgrind.mk
@@ -5,8 +5,8 @@
#############################################################
VALGRIND_SITE:=http://developer.kde.org/~sewardj
-VALGRIND_DIR:=$(BUILD_DIR)/valgrind-20020601
-VALGRIND_SOURCE:=valgrind-20020601.tar.bz2
+VALGRIND_DIR:=$(BUILD_DIR)/valgrind-1.0pre6
+VALGRIND_SOURCE:=valgrind-1.0pre6.tar.bz2
$(DL_DIR)/$(VALGRIND_SOURCE):
wget -P $(DL_DIR) --passive-ftp $(VALGRIND_SITE)/$(VALGRIND_SOURCE)
@@ -32,6 +32,7 @@ $(VALGRIND_DIR)/valgrind: $(VALGRIND_DIR)/.configured
$(TARGET_DIR)/usr/bin/valgrind: $(VALGRIND_DIR)/valgrind
make CC=$(TARGET_CC1) DESTDIR=$(TARGET_DIR) -C $(VALGRIND_DIR) install
+ rm -rf $(TARGET_DIR)/usr/share/doc/valgrind
valgrind: $(TARGET_DIR)/usr/bin/valgrind
diff --git a/sources/valgrind.patch b/sources/valgrind.patch
new file mode 100644
index 000000000..7f0b2a88a
--- /dev/null
+++ b/sources/valgrind.patch
@@ -0,0 +1,18 @@
+--- build/valgrind-1.0pre6.orig/vg_libpthread.c Sat Jul 13 06:59:27 2002
++++ build/valgrind-1.0pre6/vg_libpthread.c Sat Jul 27 02:50:53 2002
+@@ -2821,6 +2821,7 @@
+
+ /* I've no idea what these are, but they get called quite a lot.
+ Anybody know? */
++#ifndef __UCLIBC__
+
+ #undef _IO_flockfile
+ void _IO_flockfile ( _IO_FILE * file )
+@@ -2837,6 +2838,7 @@
+ }
+ weak_alias(_IO_funlockfile, funlockfile);
+
++#endif
+
+ /* This doesn't seem to be needed to simulate libpthread.so's external
+ interface, but many people complain about its absence. */