summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-11-21 08:56:14 +0000
committerEric Andersen <andersen@codepoet.org>2002-11-21 08:56:14 +0000
commit7b3014ef3f4c48af5f1002a5797c6878f1682fc6 (patch)
tree46434831b3455c659d338fccfe340af7f680bcf3
parentb2a0d2216648564a815896756588a2d94610181e (diff)
Update to the newly released gcc 3.2.1
-Erik
-rw-r--r--make/uclibc_toolchain.mk4
-rw-r--r--sources/gcc-002-swfp.patch52
2 files changed, 54 insertions, 2 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 36a9d3dfb..ba7cb4f0f 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -60,8 +60,8 @@ UCLIBC_SITE:=http://www.kernel.org/pub/linux/libs/uclibc
endif
GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/
-GCC_SOURCE:=gcc-3.2.tar.gz
-GCC_DIR:=$(BUILD_DIR)/gcc-3.2
+GCC_SOURCE:=gcc-3.2.1.tar.gz
+GCC_DIR:=$(BUILD_DIR)/gcc-3.2.1
GCC_BUILD_DIR1:=$(BUILD_DIR)/gcc-initial
GCC_BUILD_DIR2:=$(BUILD_DIR)/gcc-final
diff --git a/sources/gcc-002-swfp.patch b/sources/gcc-002-swfp.patch
new file mode 100644
index 000000000..34e6566a9
--- /dev/null
+++ b/sources/gcc-002-swfp.patch
@@ -0,0 +1,52 @@
+diff -urN gcc-3.2/gcc/config/mips/t-linux gcc-3.2-patched/gcc/config/mips/t-linux
+--- gcc-3.2.orig/gcc/config/mips/t-linux Wed Jan 16 17:22:02 2002
++++ gcc-3.2/gcc/config/mips/t-linux Mon Nov 11 15:23:33 2002
+@@ -1,3 +1,48 @@
++# Don't run fixproto
++STMP_FIXPROTO =
++
++# Don't install "assert.h" in gcc. We use the one in glibc.
++INSTALL_ASSERT_H =
++
++# nop@nop.com: -fdata-sections messes with crtstuff.c's strategy to get
++# ctors/dtors/eh in special sections.
++CRTSTUFF_T_CFLAGS = -fno-data-sections
++CRTSTUFF_T_CFLAGS_S = -fno-data-sections
++# Hopefully that's enough.
++
++# Do not build libgcc1. Let gcc generate those functions. The GNU/Linux
++# C library can handle them.
++LIBGCC1 =
++CROSS_LIBGCC1 =
++LIBGCC1_TEST =
++
++# Standard softfloat incantation:
++
++LIB2FUNCS_EXTRA = fp-bit.c dp-bit.c
++
++dp-bit.c: $(srcdir)/config/fp-bit.c
++ echo '#ifdef __MIPSEL__' > dp-bit.c
++ echo '#define FLOAT_BIT_ORDER_MISMATCH' >> dp-bit.c
++ echo '#endif' >> dp-bit.c
++ echo '#undef US_SOFTWARE_GOFAST' >> dp-bit.c
++ echo '#undef FLOAT' >> dp-bit.c
++ cat $(srcdir)/config/fp-bit.c >> dp-bit.c
++
++fp-bit.c: $(srcdir)/config/fp-bit.c
++ echo '#ifdef __MIPSEL__' > fp-bit.c
++ echo '#define FLOAT_BIT_ORDER_MISMATCH' >> fp-bit.c
++ echo '#endif' >> fp-bit.c
++ echo '#undef US_SOFTWARE_GOFAST' >> fp-bit.c
++ echo '#define FLOAT' >> fp-bit.c
++ cat $(srcdir)/config/fp-bit.c >> fp-bit.c
++
++MULTILIB_OPTIONS = msoft-float
++MULTILIB_DIRNAMES = soft-float
++MULTILIB_MATCHES =
++MULTILIB_EXTRA_OPTS =
++
++LIBGCC = stmp-multilib
++INSTALL_LIBGCC = install-multilib
+ # We want fine grained libraries, so use the new code to build the
+ # floating point emulation libraries.
+ FPBIT = fp-bit.c