summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-09-02 12:22:02 +0000
committerEric Andersen <andersen@codepoet.org>2003-09-02 12:22:02 +0000
commit92cecf265ec79ad2f633dbdebddb1a4238002d7a (patch)
treea1d748b8a10c02cb17583f70b8d55e5f661e5562
parentc9e50edded82304cbd360433f14b4f00e5159a59 (diff)
Make sure binutils does not leak system libraries into the build.
patch from mjn3 to prevent gcc using broken include paths
-rw-r--r--make/uclibc_toolchain.mk2
-rw-r--r--sources/gcc-006-include-search.patch18
2 files changed, 19 insertions, 1 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 94e3823cf..cdc5321a7 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -148,8 +148,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
--mandir=$(STAGING_DIR)/man \
--infodir=$(STAGING_DIR)/info \
--enable-targets=$(GNU_TARGET_NAME) \
- --with-lib-path="/usr/lib:/lib" \
--with-sysroot=$(STAGING_DIR) \
+ --with-lib-path="$(STAGING_DIR)/usr/lib:$(STAGING_DIR)/lib" \
$(MULTILIB) \
--program-prefix=$(ARCH)-uclibc-);
touch $(BINUTILS_DIR1)/.configured
diff --git a/sources/gcc-006-include-search.patch b/sources/gcc-006-include-search.patch
new file mode 100644
index 000000000..44a310abe
--- /dev/null
+++ b/sources/gcc-006-include-search.patch
@@ -0,0 +1,18 @@
+--- gcc-3.3.1/gcc/cppinit.c.old 2003-08-29 17:08:57.000000000 -0500
++++ gcc-3.3.1/gcc/cppinit.c 2003-08-29 16:53:36.000000000 -0500
+@@ -787,6 +787,7 @@
+ if (path != 0 && *path != 0)
+ path_include (pfile, path, SYSTEM);
+
++#if 0
+ /* Search "translated" versions of GNU directories.
+ These have /usr/local/lib/gcc... replaced by specd_prefix. */
+ if (specd_prefix != 0 && cpp_GCC_INCLUDE_DIR_len)
+@@ -824,6 +825,7 @@
+ }
+ }
+ }
++#endif
+
+ /* Search ordinary names for GNU include directories. */
+ for (p = cpp_include_defaults; p->fname; p++)