summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2010-12-26 17:16:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-28 20:33:20 +0100
commita68640c31dbf216eb5862d76daefce4b7e754795 (patch)
treee5710662cb4cc117b55a4d2be84ebf961349684a
parent58ddf43464ab3892d2af0c3973e6d9ef31653fdf (diff)
package: avoid copying .m4 files from host to staging
Since we are preparing a package generation mechanism, we would like to avoid packages that move/touch/modify files which are not part of their own package. That's why we try to not install host files into the staging directory (in this case .m4 files) and instead we include $(HOST_DIR)/usr/share/aclocal into autoreconf search directory. Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/autoconf/autoconf.mk2
-rw-r--r--package/automake/automake.mk1
-rw-r--r--package/libtool/libtool.mk9
-rw-r--r--package/pkg-config/pkg-config.mk7
4 files changed, 2 insertions, 17 deletions
diff --git a/package/autoconf/autoconf.mk b/package/autoconf/autoconf.mk
index a21192f22..0ff0644f9 100644
--- a/package/autoconf/autoconf.mk
+++ b/package/autoconf/autoconf.mk
@@ -23,4 +23,4 @@ $(eval $(call AUTOTARGETS,package,autoconf,host))
# variables used by other packages
AUTOCONF:=$(HOST_DIR)/usr/bin/autoconf
AUTOHEADER:=$(HOST_DIR)/usr/bin/autoheader
-AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)"
+AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)" -I "$(ACLOCAL_HOST_DIR)"
diff --git a/package/automake/automake.mk b/package/automake/automake.mk
index e2ff9b25b..6ee3121f3 100644
--- a/package/automake/automake.mk
+++ b/package/automake/automake.mk
@@ -23,4 +23,5 @@ $(eval $(call AUTOTARGETS,package,automake,host))
# variables used by other packages
AUTOMAKE = $(HOST_DIR)/usr/bin/automake
ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
+ACLOCAL_HOST_DIR = $(HOST_DIR)/usr/share/aclocal
ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index 60fee9fd2..330624405 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -7,15 +7,6 @@ LIBTOOL_VERSION = 2.2.10
LIBTOOL_SOURCE = libtool-$(LIBTOOL_VERSION).tar.gz
LIBTOOL_SITE = $(BR2_GNU_MIRROR)/libtool
-define HOST_LIBTOOL_CUSTOM_INSTALL
- install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/libtool.m4 \
- $(STAGING_DIR)/usr/share/aclocal/libtool.m4
- install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/ltdl.m4 \
- $(STAGING_DIR)/usr/share/aclocal/ltdl.m4
-endef
-
-HOST_LIBTOOL_POST_INSTALL_HOOKS += HOST_LIBTOOL_CUSTOM_INSTALL
-
HOST_LIBTOOL_LIBTOOL_PATCH = NO
$(eval $(call AUTOTARGETS,package,libtool))
diff --git a/package/pkg-config/pkg-config.mk b/package/pkg-config/pkg-config.mk
index 330b16603..d0bc42478 100644
--- a/package/pkg-config/pkg-config.mk
+++ b/package/pkg-config/pkg-config.mk
@@ -15,13 +15,6 @@ HOST_PKG_CONFIG_CONF_OPT = \
--with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
--disable-static
-define HOST_PKG_CONFIG_INSTALL_M4
-install -D -m 0644 $(HOST_DIR)/usr/share/aclocal/pkg.m4 \
- $(STAGING_DIR)/usr/share/aclocal/pkg.m4
-endef
-
-HOST_PKG_CONFIG_POST_INSTALL_HOOKS += HOST_PKG_CONFIG_INSTALL_M4
-
$(eval $(call AUTOTARGETS,package,pkg-config))
$(eval $(call AUTOTARGETS,package,pkg-config,host))