summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-25 02:38:28 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-25 02:38:28 +0000
commita777f26c3252c64928e970f83f2aabe494bacf87 (patch)
tree5d06bb53d5c9522035a720e1b079e1b05679f438
parent989fc8ef5943bba7722b0231db95569129aa92f6 (diff)
pdinoto writes:
This patch adds an option in GCC config to compile Objective-C language support in the toolchain. It is disabled by default, so it is not intrusive.
-rw-r--r--toolchain/gcc/Config.in7
-rw-r--r--toolchain/gcc/gcc-uclibc-3.x.mk4
2 files changed, 11 insertions, 0 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 9403aba27..3bce26efd 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -74,3 +74,10 @@ config BR2_INSTALL_LIBGCJ
depends on BR2_INSTALL_LIBSTDCPP
help
Build/install java compiler and libgcj?
+
+config BR2_INSTALL_OBJC
+ bool "Build/install Objective-C compiler and runtime?"
+ default n
+ help
+ Build/install Objective-C compiler and runtime?
+
diff --git a/toolchain/gcc/gcc-uclibc-3.x.mk b/toolchain/gcc/gcc-uclibc-3.x.mk
index 3457b4a69..0e400c236 100644
--- a/toolchain/gcc/gcc-uclibc-3.x.mk
+++ b/toolchain/gcc/gcc-uclibc-3.x.mk
@@ -49,6 +49,10 @@ TARGET_LANGUAGES:=c
endif
endif
+ifeq ($(BR2_INSTALL_OBJC),y)
+TARGET_LANGUAGES:=$(TARGET_LANGUAGES),objc
+endif
+
#############################################################
#
# build the first pass gcc compiler