summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-11-25 11:07:08 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-25 11:07:08 +0100
commitb9c5809a0bd697612da9185df03a17a0f699eb73 (patch)
tree71cd6898ef8bc8f391b85b0ce949e2dbd206342f
parentbde876cdd373ce49f34e810169d86c279d959a16 (diff)
dialog: fix build, ensure host includes aren't used
configure looks for libintl, so ensure it is available. Also make sure the host ncurses headers aren't used. Fix up Config.in indentation while we're at it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--CHANGES8
-rw-r--r--package/dialog/Config.in16
-rw-r--r--package/dialog/dialog.mk5
3 files changed, 17 insertions, 12 deletions
diff --git a/CHANGES b/CHANGES
index e703a0732..8218e3db8 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,10 +4,10 @@
Add support for LEON Sparc architecture variants.
- Updated/fixed packages: bash, bind, busybox, gpsd, libglib2,
- libcurl, libmad, lrzsz, midori, module-init-tools, mtd-utils,
- openssh, openssl, pciutils, php, qt, sqlite, sysstat, webkit,
- zlib
+ Updated/fixed packages: bash, bind, busybox, dialog, gpsd,
+ libglib2, libcurl, libmad, lrzsz, midori, module-init-tools,
+ mtd-utils, openssh, openssl, pciutils, php, qt, sqlite,
+ sysstat, webkit, zlib
Issues resolved (http://bugs.uclibc.org):
diff --git a/package/dialog/Config.in b/package/dialog/Config.in
index 5681d1eb5..9d3462ec4 100644
--- a/package/dialog/Config.in
+++ b/package/dialog/Config.in
@@ -1,10 +1,10 @@
config BR2_PACKAGE_DIALOG
- bool "dialog"
- select BR2_PACKAGE_NCURSES
- help
- dialog - display dialog boxes from shell scripts
-
- This application provides a method of displaying several different
- types of dialog boxes from shell scripts. This allows a developer
- of a script to interact with the user in a much friendlier manner.
+ bool "dialog"
+ select BR2_PACKAGE_NCURSES
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
+ help
+ dialog - display dialog boxes from shell scripts
+ This application provides a method of displaying several different
+ types of dialog boxes from shell scripts. This allows a developer
+ of a script to interact with the user in a much friendlier manner.
diff --git a/package/dialog/dialog.mk b/package/dialog/dialog.mk
index e8c2a0d18..e8f025f75 100644
--- a/package/dialog/dialog.mk
+++ b/package/dialog/dialog.mk
@@ -7,8 +7,13 @@ DIALOG_VERSION:=1.1-20100428
DIALOG_SOURCE:=dialog-$(DIALOG_VERSION).tgz
DIALOG_SITE:=ftp://invisible-island.net/dialog
DIALOG_CONF_OPT = --with-ncurses
+DIALOG_CONF_ENV = ac_cv_path_NCURSES_CONFIG=true LIBS=-lncurses
DIALOG_DEPENDENCIES = ncurses
+ifneq ($(BR2_ENABLE_LOCALE),y)
+DIALOG_DEPENDENCIES+=libiconv
+endif
+
define DIALOG_INSTALL_TARGET_CMDS
install -c $(@D)/dialog $(TARGET_DIR)/usr/bin/dialog
endef