summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-11-04 20:31:25 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-05 10:21:17 +0100
commit5f71fc1f19c21676f029b63499e0341a89cf2049 (patch)
tree28480df4b4c6ec4db29484316e6542c333842753 /Makefile
parent504a4ad0bbd4b1cad719a82619f814433cc29822 (diff)
Remove support for shared configuration cache
The configuration cache shared between packages, while being in principle a nice idea to speed-up the configuration of packages by avoiding repetitive identical checks, turned out to be unreliable due to the subtle differences between similar but not identical checks in different packages. After spending some time trying to fix those, we concluded that supporting the shared configuration cache is definitely too hard and too unreliable, and that we'd better get rid of it altogether. This patch therefore removes the shared configuration cache infrastructure and usage. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 0 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 3664c9603..18ca8b33d 100644
--- a/Makefile
+++ b/Makefile
@@ -447,15 +447,6 @@ external-deps:
show-targets:
@echo $(TARGETS)
-ifeq ($(BR2_CONFIG_CACHE),y)
-# drop configure caches if configuration is changed
-$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config
- rm -f $@
- touch $@
-
-$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
-endif
-
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig