summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-10-31 17:35:12 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-03 23:31:04 +0100
commit8258df279ab3e87ae1e9e63074ac93c8f3cf73c1 (patch)
tree557fb017b5d439d989719a976bfe40839c0a3747 /Makefile
parent20106a052e201c280f814380ea78d4509a356f21 (diff)
Makefile: compute the version string for all to use
Some packages use the buildroot version string (to set their own version string). Computing the version string globally will makes it easy for them to use it instead of re-computing it in every packages. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8d53778b3..d6a76282d 100644
--- a/Makefile
+++ b/Makefile
@@ -35,6 +35,10 @@ CONFIG_CONFIG_IN=Config.in
CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
+# Compute the full local version string so packages can use it as-is
+# Need to export it, so it can be got from environment in children (eg. mconf)
+export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion)
+
noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \