summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-01 12:04:28 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-01 12:04:28 +0000
commit926646d9cab1bf66292eec51091d836f620b5e57 (patch)
treea6eb55101469af7e2bcd9c28fa254e54ec13f22f /Makefile
parent555a7f5e50ef3ea60920bddfd35b9945bf78c5eb (diff)
Makefile: remove target pkgconfig files if BR2_HAVE_DEVFILES isn't enabled
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fcf69ce25..15529f786 100644
--- a/Makefile
+++ b/Makefile
@@ -332,7 +332,7 @@ target-devfiles:
ifeq ($(BR2_HAVE_DEVFILES),y)
( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
- rm -rf $(TARGET_DIR)/usr/include
+ rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
find $(TARGET_DIR)/usr/lib -name '*.a' -delete
find $(TARGET_DIR)/lib -name '*.a' -delete
find $(TARGET_DIR)/usr/lib -name '*.la' -delete