summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-02-03 22:03:29 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-02-07 11:39:41 +0100
commit134ab1ce4f34837587d68e7b4f9fabd5cfc4a537 (patch)
treeffdb52fadec15a834f72701206d9f62f0cd8d1f0 /Makefile
parent3ec57751fa54a1c8ad7d974a7e5a036af68d935c (diff)
make release: add html/text/pdf manual and create .tar.bz2 format as well
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 7aeee962f..e1621f965 100644
--- a/Makefile
+++ b/Makefile
@@ -695,8 +695,15 @@ endif
release: OUT=buildroot-$(BR2_VERSION)
+# Create release tarballs. We need to fiddle a bit to add the generated
+# documentation to the git output
release:
- git archive --format=tar --prefix=$(OUT)/ master|gzip -9 >$(OUT).tar.gz
+ git archive --format=tar --prefix=$(OUT)/ master > $(OUT).tar
+ $(MAKE) O=$(OUT) manual-html manual-txt manual-pdf
+ tar rf $(OUT).tar $(OUT)
+ gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
+ bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
+ rm -rf $(OUT) $(OUT).tar
################################################################################
# GENDOC -- generates the make targets needed to build a specific type of