summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-03-11 12:16:39 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-13 13:10:29 +0100
commit2b91ab7a20cf17db16cf3c8a93ef4e50dfb585b7 (patch)
treeb3f6ffc03c87d2560cc2eb633afdc911dcce9f58 /Makefile
parentfbc242d78803a940f771d19f08e6a6959a4e7608 (diff)
Add target to print buildroot version
It's convenient to have a target to print the buildroot version, for use in external scripts calling buildroot. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d508888b3..30099d99d 100644
--- a/Makefile
+++ b/Makefile
@@ -48,7 +48,7 @@ export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/support/scripts/setloca
noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
- source-check
+ source-check print-version
# Strip quotes and then whitespaces
qstrip=$(strip $(subst ",,$(1)))
@@ -721,6 +721,9 @@ release:
bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2
rm -rf $(OUT) $(OUT).tar
+print-version:
+ @echo $(BR2_VERSION_FULL)
+
################################################################################
# GENDOC -- generates the make targets needed to build a specific type of
# asciidoc documentation.