summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-04-28 07:14:50 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 23:38:53 +0200
commit33f454bbef77638a29ec24807e30740323e15b3e (patch)
tree402c9aeb09262fb4f6a4ab83a2b526bd80fed78c /Makefile
parent2f764a26334fb07292545265e2ae9e5858794677 (diff)
config: make it possible to specify which config file to use for 'make defconfig'
So that this works: % make defconfig BR2_DEFCONFIG=~/buildroot-defconfig Right now we have to do: % cp ~/buildroot-defconfig configs/buildroot_defconfig % make buildroot_defconfig That would dirty the buildroot tree and requires it to be writable. Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Luca Ceresoli <luca@lucaceresoli.net> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index cc8124abb..a7625ba0e 100644
--- a/Makefile
+++ b/Makefile
@@ -540,7 +540,7 @@ silentoldconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
defconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
- @$(COMMON_CONFIG_ENV) $< --defconfig $(CONFIG_CONFIG_IN)
+ @$(COMMON_CONFIG_ENV) $< --defconfig$(if $(BR2_DEFCONFIG),=$(BR2_DEFCONFIG)) $(CONFIG_CONFIG_IN)
%_defconfig: $(BUILD_DIR)/buildroot-config/conf $(TOPDIR)/configs/%_defconfig outputmakefile
@mkdir -p $(BUILD_DIR)/buildroot-config
@@ -603,6 +603,7 @@ help:
@echo ' oldconfig - resolve any unresolved symbols in .config'
@echo ' randconfig - New config with random answer to all options'
@echo ' defconfig - New config with default answer to all options'
+ @echo ' BR2_DEFCONFIG, if set, is used as input'
@echo ' savedefconfig - Save current config as ./defconfig (minimal config)'
@echo ' allyesconfig - New config where all options are accepted with yes'
@echo ' allnoconfig - New config where all options are answered with no'