summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-28 19:46:58 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-09-28 19:46:58 +0000
commit356133b4f38461bcc2b928699fbec3d78fda84d7 (patch)
treeda95bf606ecea5945524e8820c683f62e183da07 /Makefile
parent5459a9c5e010ef0cab22037432ea9d4984c83d6b (diff)
Add some more host tools
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cb030252e..b34fe2fb1 100644
--- a/Makefile
+++ b/Makefile
@@ -91,18 +91,26 @@ endif
ifndef HOSTCXX
HOSTCXX:=g++
endif
+ifndef HOSTCPP
+HOSTCPP:=cpp
+endif
ifndef HOSTLD
HOSTLD:=ld
endif
ifndef HOSTLN
HOSTLN:=ln
endif
+ifndef HOSTNM
+HOSTNM:=nm
+endif
HOSTAR:=$(shell $(CONFIG_SHELL) -c "which $(HOSTAR)" || type -p $(HOSTAR) || echo ar)
HOSTAS:=$(shell $(CONFIG_SHELL) -c "which $(HOSTAS)" || type -p $(HOSTAS) || echo as)
HOSTCC:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCC)" || type -p $(HOSTCC) || echo gcc)
HOSTCXX:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCXX)" || type -p $(HOSTCXX) || echo g++)
+HOSTCPP:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCPP)" || type -p $(HOSTCPP) || echo cpp)
HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
+HOSTNM:=$(shell $(CONFIG_SHELL) -c "which $(HOSTNM)" || type -p $(HOSTNM) || echo nm)
ifndef CFLAGS_FOR_BUILD
CFLAGS_FOR_BUILD:=-g -O2
endif