summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-18 18:07:19 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-18 18:07:19 +0000
commit62b5ae4b66f214fb2f105590bdac14133f0cdc20 (patch)
treee5371fb6c1bc8f7d9736ed05a2af892731bfdf92 /Makefile
parent88494a7bbebf55051368175c146dc9ff1e6a34fd (diff)
Fix INITRAMFS target that was broken. Get rid of config stuff out of the top-level directory. Finally fix Linux kernel module building such that modules are built and installed first followed by rest of packages. This allows for packages to build external Linux kernel modules.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile45
1 files changed, 24 insertions, 21 deletions
diff --git a/Makefile b/Makefile
index 65752ea95..a4d09eb89 100644
--- a/Makefile
+++ b/Makefile
@@ -187,6 +187,9 @@ include .config.cmd
# each selected package to TARGETS if that package was selected
# in the .config file.
include toolchain/*/*.mk
+ifeq ($(BR2_PACKAGE_LINUX),y)
+TARGETS+=linux26-modules
+endif
include package/*/*.mk
# target stuff is last so it can override anything else
@@ -309,47 +312,47 @@ $(CONFIG)/mconf:
fi
menuconfig: $(CONFIG)/mconf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
config: $(CONFIG)/conf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf $(CONFIG_CONFIG_IN)
oldconfig: $(CONFIG)/conf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
randconfig: $(CONFIG)/conf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
allyesconfig: $(CONFIG)/conf
cat $(CONFIG_DEFCONFIG) > .config
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
#sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
allnoconfig: $(CONFIG)/conf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
defconfig: $(CONFIG)/conf
- @-mkdir -p include/config
- @KCONFIG_AUTOCONFIG=include/config/auto.conf \
- KCONFIG_AUTOHEADER=include/autoconf.h \
+ @-mkdir -p $(CONFIG)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
# check if download URLs are outdated