summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-06-30 10:29:22 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-07-01 00:27:39 +0200
commit670cb306704d76b4c3b717931cc7abef8c693099 (patch)
tree045a767c18ca54f1938c6f63d8539a97c54c69cc /Makefile
parent96885ca7eb4a05e65986334d6138e1fe6afa46fc (diff)
Globally disable PKG_CONFIG_PATH
If PKG_CONFIG_PATH is set in the environment, it allows pkg-config to look for libraries outside of the buildroot tree. This is a problem both for host and target builds. To avoid it, globally set an empty PKG_CONFIG_PATH in the environment. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7a66897cc..bcbe9fc10 100644
--- a/Makefile
+++ b/Makefile
@@ -165,6 +165,9 @@ HOSTNM:=$(shell which $(HOSTNM) || type -p $(HOSTNM) || echo nm)
export HOSTAR HOSTAS HOSTCC HOSTCXX HOSTFC HOSTLD
export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
+# Make sure pkg-config doesn't look outside the buildroot tree
+unexport PKG_CONFIG_PATH
+
# bash prints the name of the directory on 'cd <dir>' if CDPATH is
# set, so unset it here to not cause problems. Notice that the export
# line doesn't affect the environment of $(shell ..) calls, so