summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 16:45:15 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-19 16:02:48 +0200
commitaba915fe2b189ca3efcb512f3d8cc0abd12fc1a3 (patch)
treec40c18a1b04ee69a66f68dd415c128a3ebfe48ff /Makefile
parent338c6d7cf278a3f694ab939f0e4254f0e81e98bb (diff)
Remove filename extension crap for OS compatibility
The only variable that is used is HOST_LOADLIBES, defined for the cygwin case in the kconfig build. Since we don't support cygwin, simply get rid of this. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile28
1 files changed, 0 insertions, 28 deletions
diff --git a/Makefile b/Makefile
index 55d552b7b..bb3a49bf9 100644
--- a/Makefile
+++ b/Makefile
@@ -195,34 +195,6 @@ unexport CONFIG_SITE
GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
-#############################################################
-#
-# Setup the proper filename extensions for the host
-#
-##############################################################
-ifneq ($(findstring linux,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=
-HOST_LIBEXT:=.a
-HOST_SHREXT:=.so
-endif
-ifneq ($(findstring apple,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=
-HOST_LIBEXT:=.a
-HOST_SHREXT:=.dylib
-endif
-ifneq ($(findstring cygwin,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=.exe
-HOST_LIBEXT:=.lib
-HOST_SHREXT:=.dll
-HOST_LOADLIBES=-lcurses -lintl
-export HOST_LOADLIBES
-endif
-ifneq ($(findstring mingw,$(GNU_HOST_NAME)),)
-HOST_EXEEXT:=.exe
-HOST_LIBEXT:=.lib
-HOST_SHREXT:=.dll
-endif
-
##############################################################
#
# The list of stuff to build for the target toolchain