summaryrefslogtreecommitdiff
path: root/boa.mk
diff options
context:
space:
mode:
authorJon Nelson <jnelson@securepipe.com>2002-01-06 18:54:35 +0000
committerJon Nelson <jnelson@securepipe.com>2002-01-06 18:54:35 +0000
commite1be1eadeea92f61f457bf53e55ea6cc0443e9aa (patch)
treeac8e294e74b6cfa3f64be792f63a3a550c161fb1 /boa.mk
parentc79e99824e064382cbbfed2bc56d5d6aae710ff0 (diff)
some more cleanups. This one works pretty well
Diffstat (limited to 'boa.mk')
-rw-r--r--boa.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/boa.mk b/boa.mk
index 00d27d61f..6b8b1b75c 100644
--- a/boa.mk
+++ b/boa.mk
@@ -34,12 +34,9 @@ $(BOA_WORKDIR)/Makefile: $(TARGET_CC) $(BOA_DIR)/.unpacked
(cd $(BOA_WORKDIR) && CC=$(TARGET_CC) $(BOA_DIR)/src/configure); \
fi
touch $(BOA_WORKDIR)/.depend
- touch $(BOA_WORKDIR)/.unpacked
-$(BOA_WORKDIR)/boa: $(BOA_WORKDIR)/Makefile
- make VPATH=$(BOA_DIR)/src/ -C $(BOA_WORKDIR)
-
-$(BOA_WORKDIR)/boa_indexer: $(BOA_WORKDIR)/Makefile
+$(BOA_WORKDIR)/boa $(BOA_WORKDIR)/boa_indexer: $(BOA_WORKDIR)/Makefile
+ rm -f $@
make VPATH=$(BOA_DIR)/src/ -C $(BOA_WORKDIR)
$(BOA_WORKDIR)/.installed: $(BOA_WORKDIR)/boa $(BOA_WORKDIR)/boa_indexer