summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-31 19:34:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-12 13:23:48 +0200
commit6db01c1b3091aec8c0131f0f559daabb27e78c1c (patch)
treedd3695f95809b4db392e347d054487718b006f4d /boot
parent4a587b12eb387e0cb44e5a1c27dc765fc98a60c3 (diff)
u-boot: add a few comments
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/u-boot/u-boot.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 220eeb2b6..90a45b87f 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -108,6 +108,7 @@ endif
endif # BR2_TARGET_UBOOT_NETWORK
touch $@
+# Build U-Boot itself
$(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
@@ -116,6 +117,7 @@ $(U_BOOT_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/.header_modified
$(MAKE) CROSS_COMPILE="$(TARGET_CROSS)" ARCH=$(U_BOOT_ARCH) \
-C $(U_BOOT_DIR)
+# Copy the result to the images/ directory
$(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
rm -f $(BINARIES_DIR)/$(U_BOOT_BIN)
cp -dpf $(U_BOOT_DIR)/$(U_BOOT_BIN) $(BINARIES_DIR)/
@@ -129,6 +131,7 @@ $(MKIMAGE): $(U_BOOT_DIR)/.patched
$(MAKE) -C $(U_BOOT_DIR) tools
cp -dpf $(U_BOOT_DIR)/tools/mkimage $(@D)
+# Build manually mkimage for the target
$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(U_BOOT_DIR)/tools \
@@ -142,6 +145,7 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
+# Build manually fw_printenv for the target
$(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/.configured
mkdir -p $(@D)
$(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \