summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 23:09:58 +0200
commit0849e8193ef429f29945b8c2a54eafc8635e0969 (patch)
tree87934d420647a042d53c0332e15d4d02404b8010 /boot
parente055aea216cff4d12cf55eab2e35ca1459edaa91 (diff)
package: remove useless arguments from GENTARGETS
Thanks to the pkgparentdir and pkgname functions, we can rewrite the GENTARGETS macro in a way that avoids the need for each package to repeat its name and the directory in which it is present. [Peter: pkgdir->pkgparentdir] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/at91bootstrap/at91bootstrap.mk2
-rw-r--r--boot/at91dataflashboot/at91dataflashboot.mk2
-rw-r--r--boot/barebox/barebox.mk2
-rw-r--r--boot/syslinux/syslinux.mk2
-rw-r--r--boot/uboot/uboot.mk2
-rw-r--r--boot/xloader/xloader.mk2
6 files changed, 6 insertions, 6 deletions
diff --git a/boot/at91bootstrap/at91bootstrap.mk b/boot/at91bootstrap/at91bootstrap.mk
index 871b0ffb4..a7a856c6e 100644
--- a/boot/at91bootstrap/at91bootstrap.mk
+++ b/boot/at91bootstrap/at91bootstrap.mk
@@ -29,7 +29,7 @@ define AT91BOOTSTRAP_INSTALL_IMAGES_CMDS
cp $(@D)/$(AT91BOOTSTRAP_BINARY) $(BINARIES_DIR)
endef
-$(eval $(call GENTARGETS,boot,at91bootstrap))
+$(eval $(call GENTARGETS))
ifeq ($(BR2_TARGET_AT91BOOTSTRAP),y)
# we NEED a board name unless we're at make source
diff --git a/boot/at91dataflashboot/at91dataflashboot.mk b/boot/at91dataflashboot/at91dataflashboot.mk
index 14fb8c54d..6c0188a1e 100644
--- a/boot/at91dataflashboot/at91dataflashboot.mk
+++ b/boot/at91dataflashboot/at91dataflashboot.mk
@@ -19,4 +19,4 @@ define AT91DATAFLASHBOOT_INSTALL_IMAGES_CMDS
cp $(@D)/DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).bin $(BINARIES_DIR)
endef
-$(eval $(call GENTARGETS,boot,at91dataflashboot))
+$(eval $(call GENTARGETS))
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index c3510fd4c..0cbe64118 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -72,7 +72,7 @@ define BAREBOX_INSTALL_TARGET_CMDS
endef
endif
-$(eval $(call GENTARGETS,boot,barebox))
+$(eval $(call GENTARGETS))
ifeq ($(BR2_TARGET_BAREBOX),y)
# we NEED a board defconfig file unless we're at make source
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index 686124fe5..fa5af0701 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -26,4 +26,4 @@ define SYSLINUX_INSTALL_IMAGES_CMDS
done
endef
-$(eval $(call GENTARGETS,boot,syslinux))
+$(eval $(call GENTARGETS))
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 202995a73..cf2231211 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -88,7 +88,7 @@ define UBOOT_INSTALL_IMAGES_CMDS
cp -dpf $(@D)/$(UBOOT_BIN) $(BINARIES_DIR)/
endef
-$(eval $(call GENTARGETS,boot,uboot))
+$(eval $(call GENTARGETS))
ifeq ($(BR2_TARGET_UBOOT),y)
# we NEED a board name unless we're at make source
diff --git a/boot/xloader/xloader.mk b/boot/xloader/xloader.mk
index 8d8cce3b9..e8dd38097 100644
--- a/boot/xloader/xloader.mk
+++ b/boot/xloader/xloader.mk
@@ -19,7 +19,7 @@ define XLOADER_INSTALL_IMAGES_CMDS
$(INSTALL) -D -m 0755 $(@D)/MLO $(BINARIES_DIR)/
endef
-$(eval $(call GENTARGETS,boot,xloader))
+$(eval $(call GENTARGETS))
#############################################################
#