summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-06 09:27:32 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-07 08:20:21 +0200
commita1c8fa41f6f6e5047182fe90656bcd30243bca8d (patch)
treecf1b67669365d0aabc1756fa5ffab71cbeaea571 /boot
parent08235f7144d08bc111b07d3523ac6439f6fd0b94 (diff)
Update all packages to quote $(TARGET_CC)
Now that TARGET_CC contains several space-separated words, it must be used quoted everywhere. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/grub/grub.mk8
-rw-r--r--boot/grub2/grub2.mk4
2 files changed, 6 insertions, 6 deletions
diff --git a/boot/grub/grub.mk b/boot/grub/grub.mk
index 3805afec6..401d34640 100644
--- a/boot/grub/grub.mk
+++ b/boot/grub/grub.mk
@@ -79,12 +79,12 @@ $(GRUB_DIR)/.configured: $(GRUB_DIR)/.unpacked
touch $@
$(GRUB_DIR)/$(GRUB_BINARY): $(GRUB_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(GRUB_DIR)
+ $(MAKE) CC="$(TARGET_CC)" -C $(GRUB_DIR)
rm -f $(GRUB_DIR)/$(GRUB_BINARY)
- $(MAKE) CC=$(TARGET_CC) CFLAGS+=-static -C $(GRUB_DIR)/grub grub
+ $(MAKE) CC="$(TARGET_CC)" CFLAGS+=-static -C $(GRUB_DIR)/grub grub
mkdir -p $(dir $(STAGING_DIR)/$(GRUB_TARGET_BINARY))
mv $(GRUB_DIR)/$(GRUB_BINARY) $(STAGING_DIR)/$(GRUB_TARGET_BINARY).static
- $(MAKE) CC=$(TARGET_CC) -C $(GRUB_DIR)/grub
+ $(MAKE) CC="$(TARGET_CC)" -C $(GRUB_DIR)/grub
$(GRUB_DIR)/.installed: $(GRUB_DIR)/$(GRUB_BINARY)
cp $(GRUB_DIR)/$(GRUB_BINARY) $(TARGET_DIR)/$(GRUB_TARGET_BINARY)
@@ -99,7 +99,7 @@ endif
grub: $(GRUB_DIR)/.installed
grub-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GRUB_DIR) uninstall
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC="$(TARGET_CC)" -C $(GRUB_DIR) uninstall
-$(MAKE) -C $(GRUB_DIR) clean
rm -f $(TARGET_DIR)/boot/grub/$(GRUB_SPLASHIMAGE) \
$(TARGET_DIR)/sbin/$(GRUB_BINARY) \
diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index 6c3bbefe3..f939d9a43 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -67,7 +67,7 @@ $(GRUB2_DIR)/.configured: $(GRUB2_DIR)/.unpacked
touch $@
$(GRUB2_DIR)/.compiled: $(GRUB2_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(@D)
+ $(MAKE) CC="$(TARGET_CC)" -C $(@D)
touch $@
$(GRUB2_DIR)/.installed: $(GRUB2_DIR)/.compiled
@@ -77,7 +77,7 @@ $(GRUB2_DIR)/.installed: $(GRUB2_DIR)/.compiled
grub2: host-automake host-autoconf $(GRUB2_DIR)/.installed
grub2-clean:
- $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GRUB2_DIR) uninstall
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC="$(TARGET_CC)" -C $(GRUB2_DIR) uninstall
-$(MAKE) -C $(GRUB2_DIR) clean
grub2-dirclean: