summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-04-24 23:32:46 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-24 23:32:46 +0200
commitcdd4a7a06184ec1a322ac43f633b5f15f991de54 (patch)
treecf59ccbda283ac8dcef0d96ecc6f463f25ba8c2a /boot
parentf3de6d578bc3f522ed066bd829cddafb6e31f22c (diff)
u-boot: fix target build of fw_printenv
Closes #3571 The current approach for building fw_printenv for the target fails on some configurations, so use the upstream make target (which works) instead. At the same time get rid of the unneeded stripping. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'boot')
-rw-r--r--boot/u-boot/u-boot.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/boot/u-boot/u-boot.mk b/boot/u-boot/u-boot.mk
index 2f839c53c..ff3f65e96 100644
--- a/boot/u-boot/u-boot.mk
+++ b/boot/u-boot/u-boot.mk
@@ -159,15 +159,11 @@ $(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/.configured
$(U_BOOT_DIR)/tools/os_support.c \
$(wildcard $(U_BOOT_DIR)/libfdt/fdt*.c $(U_BOOT_DIR)/lib/libfdt/fdt*.c)
- $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
-
# Build manually fw_printenv for the target
$(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/.configured
- mkdir -p $(@D)
- $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
- -DUSE_HOSTCC -o $@ \
- $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/lib*/crc32.c
- $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
+ $(TARGET_CONFIGURE_OPTS) \
+ $(MAKE) HOSTCC="$(TARGET_CC)" -C $(U_BOOT_DIR) env
+ $(INSTALL) -m 0755 -D $(U_BOOT_DIR)/tools/env/fw_printenv $@
ln -sf fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
u-boot: $(U_BOOT_TARGETS)