summaryrefslogtreecommitdiff
path: root/boot
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-03 00:07:32 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-17 20:23:05 +0200
commite1502ebc0c92763896c53d405ee9c7c7a1a33e24 (patch)
tree38066478ac2cc481a3588a15ff5410129fb4c47c /boot
parent46fa5cbfb8f4a94680dc0880db051eb8acee6a17 (diff)
all packages: rename XXXTARGETS to xxx-package
Also remove the redundant $(call ...). This is a purely mechanical change, performed with find package linux toolchain boot -name \*.mk | \ xargs sed -i -e 's/$(eval $(call GENTARGETS))/$(eval $(generic-package))/' \ -e 's/$(eval $(call AUTOTARGETS))/$(eval $(autotools-package))/' \ -e 's/$(eval $(call CMAKETARGETS))/$(eval $(cmake-package))/' Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'boot')
-rw-r--r--boot/at91bootstrap/at91bootstrap.mk2
-rw-r--r--boot/at91dataflashboot/at91dataflashboot.mk2
-rw-r--r--boot/barebox/barebox.mk2
-rw-r--r--boot/grub/grub.mk2
-rw-r--r--boot/lpc32xxcdl/lpc32xxcdl.mk2
-rw-r--r--boot/syslinux/syslinux.mk2
-rw-r--r--boot/uboot/uboot.mk2
-rw-r--r--boot/xloader/xloader.mk2
8 files changed, 8 insertions, 8 deletions
diff --git a/boot/at91bootstrap/at91bootstrap.mk b/boot/at91bootstrap/at91bootstrap.mk
index 5592d3737..d8caed71d 100644
--- a/boot/at91bootstrap/at91bootstrap.mk
+++ b/boot/at91bootstrap/at91bootstrap.mk
@@ -38,7 +38,7 @@ define AT91BOOTSTRAP_INSTALL_IMAGES_CMDS
cp $(@D)/$(AT91BOOTSTRAP_BINARY) $(BINARIES_DIR)
endef
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
ifeq ($(BR2_TARGET_AT91BOOTSTRAP),y)
# we NEED a board name unless we're at make source
diff --git a/boot/at91dataflashboot/at91dataflashboot.mk b/boot/at91dataflashboot/at91dataflashboot.mk
index 6c0188a1e..10f54a1e5 100644
--- a/boot/at91dataflashboot/at91dataflashboot.mk
+++ b/boot/at91dataflashboot/at91dataflashboot.mk
@@ -19,4 +19,4 @@ define AT91DATAFLASHBOOT_INSTALL_IMAGES_CMDS
cp $(@D)/DataflashBoot-$(AT91DATAFLASHBOOT_VERSION).bin $(BINARIES_DIR)
endef
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index 0cbe64118..e5e2558cb 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -72,7 +72,7 @@ define BAREBOX_INSTALL_TARGET_CMDS
endef
endif
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
ifeq ($(BR2_TARGET_BAREBOX),y)
# we NEED a board defconfig file unless we're at make source
diff --git a/boot/grub/grub.mk b/boot/grub/grub.mk
index 1b5ca0dd2..e8d66f175 100644
--- a/boot/grub/grub.mk
+++ b/boot/grub/grub.mk
@@ -82,4 +82,4 @@ define GRUB_UNINSTALL_TARGET_CMDS
rm -rf $(TARGET_DIR)/boot/grub
endef
-$(eval $(call AUTOTARGETS))
+$(eval $(autotools-package))
diff --git a/boot/lpc32xxcdl/lpc32xxcdl.mk b/boot/lpc32xxcdl/lpc32xxcdl.mk
index d11be6cf2..c4e8d2dc1 100644
--- a/boot/lpc32xxcdl/lpc32xxcdl.mk
+++ b/boot/lpc32xxcdl/lpc32xxcdl.mk
@@ -67,4 +67,4 @@ define LPC32XXCDL_INSTALL_IMAGES_CMDS
cp $(@D)/$(LPC32XXCDL_BOARD_STARTUP_DIR)/$(LPC32XXCDL_S1L)/*gnu.bin $(BINARIES_DIR)
endef
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
diff --git a/boot/syslinux/syslinux.mk b/boot/syslinux/syslinux.mk
index 50dec2bbb..7df342fb1 100644
--- a/boot/syslinux/syslinux.mk
+++ b/boot/syslinux/syslinux.mk
@@ -42,5 +42,5 @@ define HOST_SYSLINUX_CLEAN_CMDS
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) clean
endef
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
$(eval $(host-generic-package))
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 486773aa7..9e03d6a61 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -119,7 +119,7 @@ UBOOT_POST_BUILD_HOOKS += UBOOT_BUILD_OMAP_IFT
UBOOT_POST_INSTALL_IMAGES_HOOKS += UBOOT_INSTALL_OMAP_IFT_IMAGE
endif
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
ifeq ($(BR2_TARGET_UBOOT),y)
# we NEED a board name unless we're at make source
diff --git a/boot/xloader/xloader.mk b/boot/xloader/xloader.mk
index e8dd38097..fbdba0283 100644
--- a/boot/xloader/xloader.mk
+++ b/boot/xloader/xloader.mk
@@ -19,7 +19,7 @@ define XLOADER_INSTALL_IMAGES_CMDS
$(INSTALL) -D -m 0755 $(@D)/MLO $(BINARIES_DIR)/
endef
-$(eval $(call GENTARGETS))
+$(eval $(generic-package))
#############################################################
#