summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-03 00:07:08 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-17 20:22:41 +0200
commit46fa5cbfb8f4a94680dc0880db051eb8acee6a17 (patch)
treea3df3b12a820f82953d8ae86397ef4fd939b94c1 /docs
parent69e64c42b7f325e6e21d063644eea51204321539 (diff)
Rename XXXTARGETS to xxx-package
With the introduction of a specific macro for host targets, it was decided to also make the names of the macros more intuitive: generic-package, autotools-package and cmake-package. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-autotargets.txt12
-rw-r--r--docs/manual/adding-packages-cmaketargets.txt12
-rw-r--r--docs/manual/adding-packages-gentargets.txt16
3 files changed, 20 insertions, 20 deletions
diff --git a/docs/manual/adding-packages-autotargets.txt b/docs/manual/adding-packages-autotargets.txt
index 09a2e7c09..f67cd060a 100644
--- a/docs/manual/adding-packages-autotargets.txt
+++ b/docs/manual/adding-packages-autotargets.txt
@@ -3,7 +3,7 @@ Infrastructure for autotools-based packages
[[autotargets-tutorial]]
-+AUTOTARGETS+ tutorial
++autotools-package+ tutorial
~~~~~~~~~~~~~~~~~~~~~~
First, let's see how to write a +.mk+ file for an autotools-based
@@ -23,7 +23,7 @@ package, with an example :
11: LIBFOO_CONF_OPT = --enable-shared
12: LIBFOO_DEPENDENCIES = libglib2 host-pkg-config
13:
-14: $(eval $(AUTOTARGETS))
+14: $(eval $(autotools-package))
------------------------
On line 6, we declare the version of the package.
@@ -57,23 +57,23 @@ and building the package.
On line 12, we declare our dependencies, so that they are built
before the build process of our package starts.
-Finally, on line line 14, we invoke the +AUTOTARGETS+
+Finally, on line line 14, we invoke the +autotools-package+
macro that generates all the Makefile rules that actually allows the
package to be built.
[[autotargets-reference]]
-+AUTOTARGETS+ reference
++autotools-package+ reference
~~~~~~~~~~~~~~~~~~~~~~~
The main macro of the autotools package infrastructure is
-+AUTOTARGETS+. It is similar to the +GENTARGETS+ macro. The ability to
++autotools-package+. It is similar to the +generic-package+ macro. The ability to
have target and host packages is also available, with the
+host-autotools-package+ macro.
Just like the generic infrastructure, the autotools infrastructure
works by defining a number of variables before calling the
-+AUTOTARGETS+ macro.
++autotools-package+ macro.
First, all the package metadata information variables that exist in the
generic infrastructure also exist in the autotools infrastructure:
diff --git a/docs/manual/adding-packages-cmaketargets.txt b/docs/manual/adding-packages-cmaketargets.txt
index a29404270..69acb00cc 100644
--- a/docs/manual/adding-packages-cmaketargets.txt
+++ b/docs/manual/adding-packages-cmaketargets.txt
@@ -3,7 +3,7 @@ Infrastructure for CMake-based packages
[[cmaketargets-tutorial]]
-+CMAKETARGETS+ tutorial
++cmake-package+ tutorial
~~~~~~~~~~~~~~~~~~~~~~~
First, let's see how to write a +.mk+ file for a CMake-based package,
@@ -23,7 +23,7 @@ with an example :
11: LIBFOO_CONF_OPT = -DBUILD_DEMOS=ON
12: LIBFOO_DEPENDENCIES = libglib2 host-pkg-config
13:
-14: $(eval $(CMAKETARGETS))
+14: $(eval $(cmake-package))
------------------------
On line 6, we declare the version of the package.
@@ -56,22 +56,22 @@ configuring the package.
On line 12, we declare our dependencies, so that they are built
before the build process of our package starts.
-Finally, on line line 14, we invoke the +CMAKETARGETS+
+Finally, on line line 14, we invoke the +cmake-package+
macro that generates all the Makefile rules that actually allows the
package to be built.
[[cmaketargets-reference]]
-+CMAKETARGETS+ reference
++cmake-package+ reference
~~~~~~~~~~~~~~~~~~~~~~~~
The main macro of the CMake package infrastructure is
-+CMAKETARGETS+. It is similar to the +GENTARGETS+ macro. The ability to
++cmake-package+. It is similar to the +generic-package+ macro. The ability to
have target and host packages is also available, with the
+host-cmake-package+ macro.
Just like the generic infrastructure, the CMake infrastructure works
-by defining a number of variables before calling the +CMAKETARGETS+
+by defining a number of variables before calling the +cmake-package+
macro.
First, all the package metadata information variables that exist in
diff --git a/docs/manual/adding-packages-gentargets.txt b/docs/manual/adding-packages-gentargets.txt
index 2e9ebef71..cc412090b 100644
--- a/docs/manual/adding-packages-gentargets.txt
+++ b/docs/manual/adding-packages-gentargets.txt
@@ -8,7 +8,7 @@ system is based on hand-written Makefiles or shell scripts.
[[gentargets-tutorial]]
-+GENTARGETS+ Tutorial
++generic-package+ Tutorial
~~~~~~~~~~~~~~~~~~~~~
------------------------------
@@ -46,7 +46,7 @@ system is based on hand-written Makefiles or shell scripts.
32: /bin/foo f 4755 0 0 - - - - -
33: endef
34:
-35: $(eval $(GENTARGETS))
+35: $(eval $(generic-package))
--------------------------------
The Makefile begins on line 6 to 8 with metadata information: the
@@ -83,16 +83,16 @@ All these steps rely on the +$(@D)+ variable, which
contains the directory where the source code of the package has been
extracted.
-Finally, on line 35, we call the +GENTARGETS+ which
+Finally, on line 35, we call the +generic-package+ which
generates, according to the variables defined previously, all the
Makefile code necessary to make your package working.
[[gentargets-reference]]
-+GENTARGETS+ Reference
++generic-package+ Reference
~~~~~~~~~~~~~~~~~~~~~~
-There are two variants of the generic target. The +GENTARGETS+ macro is
+There are two variants of the generic target. The +generic-package+ macro is
used for packages to be cross-compiled for the target. The
+host-generic-package+ macro is used for host packages, natively compiled
for the host. It is possible to call both of them in a single +.mk+
@@ -100,7 +100,7 @@ file: once to create the rules to generate a target
package and once to create the rules to generate a host package:
----------------------
-$(eval $(GENTARGETS))
+$(eval $(generic-package))
$(eval $(host-generic-package))
----------------------
@@ -112,10 +112,10 @@ some tools to be installed on the host. If the package name is
variables of other packages, if they depend on +libfoo+ or
+host-libfoo+.
-The call to the +GENTARGETS+ and/or +host-generic-package+ macro *must* be
+The call to the +generic-package+ and/or +host-generic-package+ macro *must* be
at the end of the +.mk+ file, after all variable definitions.
-For the target package, the +GENTARGETS+ uses the variables defined by
+For the target package, the +generic-package+ uses the variables defined by
the .mk file and prefixed by the uppercased package name:
+LIBFOO_*+. +host-generic-package+ uses the +HOST_LIBFOO_*+ variables. For
'some' variables, if the +HOST_LIBFOO_+ prefixed variable doesn't