summaryrefslogtreecommitdiff
path: root/fs/initramfs/initramfs.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/initramfs/initramfs.mk
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/initramfs/initramfs.mk')
-rw-r--r--fs/initramfs/initramfs.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/fs/initramfs/initramfs.mk b/fs/initramfs/initramfs.mk
new file mode 100644
index 000000000..cf1fcdbae
--- /dev/null
+++ b/fs/initramfs/initramfs.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# Make a initramfs_list file to be used by gen_init_cpio
+# gen_init_cpio is part of the 2.6 linux kernels to build an
+# initial ramdisk filesystem based on cpio
+#
+#############################################################
+
+define ROOTFS_INITRAMFS_INIT_SYMLINK
+ rm -f $(TARGET_DIR)/init
+ ln -s sbin/init $(TARGET_DIR)/init
+endef
+
+define ROOTFS_INITRAMFS_CMD
+ $(SHELL) target/initramfs/gen_initramfs_list.sh -u 0 -g 0 $(TARGET_DIR) > $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,initramfs)) \ No newline at end of file