summaryrefslogtreecommitdiff
path: root/fs/squashfs/squashfs.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:31:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit3474716bff31a3d287d0d3813eb7e107cedfa3ef (patch)
treea9147e6975f19c05791e7886c628f968c2258ef7 /fs/squashfs/squashfs.mk
parent0585241505cfaddc9db6ae92739bdfb5ce5f9794 (diff)
Coherent naming for .mk files in fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/squashfs/squashfs.mk')
-rw-r--r--fs/squashfs/squashfs.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
new file mode 100644
index 000000000..d72388ebf
--- /dev/null
+++ b/fs/squashfs/squashfs.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# Build the squashfs root filesystem image
+#
+#############################################################
+
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+
+define ROOTFS_SQUASHFS_CMD
+ $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend
+endef
+
+$(eval $(call ROOTFS_TARGET,squashfs)) \ No newline at end of file