summaryrefslogtreecommitdiff
path: root/fs/ubifs/ubifs.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:31:32 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit3474716bff31a3d287d0d3813eb7e107cedfa3ef (patch)
treea9147e6975f19c05791e7886c628f968c2258ef7 /fs/ubifs/ubifs.mk
parent0585241505cfaddc9db6ae92739bdfb5ce5f9794 (diff)
Coherent naming for .mk files in fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/ubifs/ubifs.mk')
-rw-r--r--fs/ubifs/ubifs.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/fs/ubifs/ubifs.mk b/fs/ubifs/ubifs.mk
new file mode 100644
index 000000000..0fad23421
--- /dev/null
+++ b/fs/ubifs/ubifs.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# Build the ubifs root filesystem image
+#
+#############################################################
+
+UBIFS_OPTS := -e $(BR2_TARGET_ROOTFS_UBIFS_LEBSIZE) -c $(BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT) -m $(BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE)
+
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB),y)
+UBIFS_OPTS += -x zlib
+endif
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_LZI),y)
+UBIFS_OPTS += -x lzo
+endif
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
+UBIFS_OPTS += -x none
+endif
+
+ROOTFS_UBIFS_DEPENDENCIES = host-mtd
+
+define ROOTFS_UBIFS_CMD
+ $(HOST_DIR)/usr/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,ubifs)) \ No newline at end of file