summaryrefslogtreecommitdiff
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-14 11:14:05 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-14 11:15:28 +0100
commitacd062778f940e91ae27643b1620e205ecd04816 (patch)
tree7f12cc7d133acfc9c1901b85e7df8247f70bcce2 /fs
parentf12b1771a10a95a2e6b13d65536c6c3c591fb5e2 (diff)
fs/ext2: remove redundant BR2_TARGET_ROOTFS_EXT2_SQUASH option
The generic fs handling does a chmod -R 0:0 $(TARGET_DIR), so there's no need for a specific option to enforce this when making an ext2fs image. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/ext2/Config.in5
-rw-r--r--fs/ext2/ext2.mk4
2 files changed, 0 insertions, 9 deletions
diff --git a/fs/ext2/Config.in b/fs/ext2/Config.in
index 535fa01e1..2af44a826 100644
--- a/fs/ext2/Config.in
+++ b/fs/ext2/Config.in
@@ -18,11 +18,6 @@ config BR2_TARGET_ROOTFS_EXT2_RESBLKS
depends on BR2_TARGET_ROOTFS_EXT2
default 0
-config BR2_TARGET_ROOTFS_EXT2_SQUASH
- bool "Make all files be owned by root"
- depends on BR2_TARGET_ROOTFS_EXT2
- default y
-
choice
prompt "Compression method"
default BR2_TARGET_ROOTFS_EXT2_NONE
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index 18a6df424..cc8da0e4d 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -6,10 +6,6 @@
EXT2_OPTS :=
-ifeq ($(BR2_TARGET_ROOTFS_EXT2_SQUASH),y)
-EXT2_OPTS += -U
-endif
-
ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)),0)
EXT2_OPTS += -b $(BR2_TARGET_ROOTFS_EXT2_BLOCKS)
endif