summaryrefslogtreecommitdiff
path: root/linux/linux-ext-ocf-linux.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-05-05 03:30:23 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-05 16:21:40 +0200
commit5308d111b72bdce228252ebe2e44e28484117c5f (patch)
tree4724a05db45449f470ce08e28c19fee403e75a2f /linux/linux-ext-ocf-linux.mk
parentf18c51657f4ab038654297ccc8fb8e00314c8b60 (diff)
ocf-linux: new package
Add the ocf-linux package and linux kernel extension. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux/linux-ext-ocf-linux.mk')
-rw-r--r--linux/linux-ext-ocf-linux.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/linux/linux-ext-ocf-linux.mk b/linux/linux-ext-ocf-linux.mk
new file mode 100644
index 000000000..faf7360e4
--- /dev/null
+++ b/linux/linux-ext-ocf-linux.mk
@@ -0,0 +1,23 @@
+##################################################
+# Linux OCF extension
+#
+# Patch the linux kernel with OCF
+##################################################
+
+ifeq ($(BR2_LINUX_KERNEL_EXT_OCF_LINUX),y)
+LINUX_DEPENDENCIES += ocf-linux
+
+# Prepare kernel patch
+# The linux-3.2.1.patch is just the main inclusion, most of the code
+# resides in the ocf/ subdir.
+# It works for older kernel versions.
+# Run tested from 2.6.38+ and build tested from 2.6.35+
+define OCF_LINUX_PREPARE_KERNEL
+ support/scripts/apply-patches.sh $(LINUX_DIR) \
+ $(OCF_LINUX_DIR)/patches/ linux-3.2.1-ocf.patch ; \
+ cp -rf $(OCF_LINUX_DIR)/ocf $(LINUX_DIR)/crypto/ocf ;
+endef
+
+LINUX_PRE_PATCH_HOOKS += OCF_LINUX_PREPARE_KERNEL
+
+endif #BR2_LINUX_EXT_OCF_LINUX