summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 15:26:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-29 00:14:21 +0200
commitb626dc0791002d61f47c53b619fcba048c40171d (patch)
treefd26a9fd03668575243163643af48deee53d760c /linux
parent3e5e39a8a25a4a085afe08bdcf46933c8d569ed7 (diff)
linux: restrict output image formats to the appropriate arches
Some Linux kernel output image formats are available on some archs, some not. For example 'uImage' is not supported on MIPS, so let's prevent the user from making this selection. Issue initially reported by Choi, David <David.Choi@Micrel.Com>. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in10
-rw-r--r--linux/linux.mk2
2 files changed, 7 insertions, 5 deletions
diff --git a/linux/Config.in b/linux/Config.in
index a7109a507..1e015b7fc 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -111,20 +111,22 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
choice
prompt "Kernel binary format"
- default BR2_LINUX_KERNEL_UIMAGE if !BR2_i386 && !BR2_x86_64
- default BR2_LINUX_KERNEL_BZIMAGE if BR2_i386 || BR2_x86_64
config BR2_LINUX_KERNEL_UIMAGE
bool "uImage"
+ depends on BR2_arm || BR2_armeb || BR2_powerpc || BR2_avr32 || BR2_sh || BR2_sh64
config BR2_LINUX_KERNEL_BZIMAGE
bool "bzImage"
+ depends on BR2_i386 || BR2_x86_64
config BR2_LINUX_KERNEL_ZIMAGE
bool "zImage"
+ depends on BR2_arm || BR2_armeb || BR2_powerpc || BR2_sparc || BR2_sh || BR2_sh64 || BR2_xtensa
-config BR2_LINUX_KERNEL_VMLINUX
- bool "vmlinux"
+config BR2_LINUX_KERNEL_VMLINUX_BIN
+ bool "vmlinux.bin"
+ depends on BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64
endchoice
diff --git a/linux/linux.mk b/linux/linux.mk
index aabecc1f6..4490023a4 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -38,7 +38,7 @@ else ifeq ($(BR2_LINUX_KERNEL_BZIMAGE),y)
LINUX26_IMAGE_NAME=bzImage
else ifeq ($(BR2_LINUX_KERNEL_ZIMAGE),y)
LINUX26_IMAGE_NAME=zImage
-else ifeq ($(BR2_LINUX_KERNEL_VMLINUX),y)
+else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)
LINUX26_IMAGE_NAME=vmlinux.bin
endif