summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorAlvaro G. M <alvaro.gamez@hazent.com>2012-03-16 14:42:53 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-18 22:21:16 +0100
commit0a4856ce27027e939fdcd350fb0b246cbda75e93 (patch)
treed21da7df0dda38cc0ff1495beb9bc7c92f43c5b1 /linux
parent6372f4e64600335b5ff7d07e3b78baf2fa6cce59 (diff)
DOWNLOAD: change $1=DIRECTORY_URL, $2=FILE_NAME to $1=FULL_FILE_URL, $2=FILE_NAME
This modifies the definition of DOWNLOAD to receive two arguments: the first one is the full URL of the file to download, whereas the second (and optional) is the name the file will have once downloaded. Same thing with the SOURCE_CHECK_WGET and SCP functions. All calls to these functions have been changed to the shortest form of the new API, except for toolchains acquisition. Since there is quite a number of different toolchains this call to DOWNLOAD is better set to the generic one. Signed-off-by: Alvaro G. M <alvaro.gamez@hazent.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Stephan Hoffmann <sho@relinux.de> Downloading Microblaze LE toolchain works on a clean install Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index ae236d45d..58cbe8e92 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -98,7 +98,7 @@ define LINUX_DOWNLOAD_PATCHES
$(if $(LINUX_PATCHES),
@$(call MESSAGE,"Download additional patches"))
$(foreach patch,$(filter ftp://% http://%,$(LINUX_PATCHES)),\
- $(call DOWNLOAD,$(dir $(patch)),$(notdir $(patch)))$(sep))
+ $(call DOWNLOAD,$(patch))$(sep))
endef
LINUX_POST_DOWNLOAD_HOOKS += LINUX_DOWNLOAD_PATCHES