summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2012-07-30 14:32:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-31 23:08:28 +0200
commit902609fbb31506dfe04f100c9c8099fbfa8095a1 (patch)
tree85945c3d904607883c1960cbbcfa154e083b552e /linux
parent69fc497df0ae51bcc8a067c849447abdeb3cb2be (diff)
Factorize the u-boot images code
This patch introduces the BR2_LINUX_KERNEL_UBOOT_IMAGE boolean to factorize more code that will be shared in the next patches that introduces other uImage-like targets. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in4
-rw-r--r--linux/linux.mk5
2 files changed, 8 insertions, 1 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 16c7ea72f..84fae910e 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -129,12 +129,16 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
# Binary format
#
+config BR2_LINUX_KERNEL_UBOOT_IMAGE
+ bool
+
choice
prompt "Kernel binary format"
config BR2_LINUX_KERNEL_UIMAGE
bool "uImage"
depends on BR2_arm || BR2_armeb || BR2_bfin || BR2_powerpc || BR2_avr32 || BR2_sh || BR2_sh64
+ select BR2_LINUX_KERNEL_UBOOT_IMAGE
config BR2_LINUX_KERNEL_BZIMAGE
bool "bzImage"
diff --git a/linux/linux.mk b/linux/linux.mk
index 099f8ba04..844ce5529 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -36,6 +36,10 @@ LINUX_PATCHES = $(call qstrip,$(BR2_LINUX_KERNEL_PATCH))
LINUX_INSTALL_IMAGES = YES
LINUX_DEPENDENCIES += host-module-init-tools
+ifeq ($(BR2_LINUX_KERNEL_UBOOT_IMAGE),y)
+ LINUX_DEPENDENCIES += host-uboot-tools
+endif
+
LINUX_MAKE_FLAGS = \
HOSTCC="$(HOSTCC)" \
HOSTCFLAGS="$(HOSTCFLAGS)" \
@@ -64,7 +68,6 @@ LINUX_IMAGE_NAME=vmImage
else
LINUX_IMAGE_NAME=uImage
endif
-LINUX_DEPENDENCIES+=host-uboot-tools
else ifeq ($(BR2_LINUX_KERNEL_BZIMAGE),y)
LINUX_IMAGE_NAME=bzImage
else ifeq ($(BR2_LINUX_KERNEL_ZIMAGE),y)