summaryrefslogtreecommitdiff
path: root/make/bridge.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /make/bridge.mk
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'make/bridge.mk')
-rw-r--r--make/bridge.mk61
1 files changed, 0 insertions, 61 deletions
diff --git a/make/bridge.mk b/make/bridge.mk
deleted file mode 100644
index 46b78b0e8..000000000
--- a/make/bridge.mk
+++ /dev/null
@@ -1,61 +0,0 @@
-#############################################################
-#
-# bridgeutils - User Space Program For Controling Bridging
-#
-#############################################################
-#
-BRIDGE_SOURCE_URL=http://umn.dl.sourceforge.net/sourceforge/bridge/
-BRIDGE_SOURCE=bridge-utils-1.0.4.tar.gz
-BRIDGE_BUILD_DIR=$(BUILD_DIR)/bridge-utils-1.0.4
-BRIDGE_TARGET_BINARY:=usr/sbin/brctl
-
-$(DL_DIR)/$(BRIDGE_SOURCE):
- $(WGET) -P $(DL_DIR) $(BRIDGE_SOURCE_URL)/$(BRIDGE_SOURCE)
-
-$(BRIDGE_BUILD_DIR)/.unpacked: $(DL_DIR)/$(BRIDGE_SOURCE)
- zcat $(DL_DIR)/$(BRIDGE_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- patch -p1 -d $(BRIDGE_BUILD_DIR) < $(SOURCE_DIR)/bridge.patch
- touch $(BRIDGE_BUILD_DIR)/.unpacked
-
-$(BRIDGE_BUILD_DIR)/.configured: $(BRIDGE_BUILD_DIR)/.unpacked
- (cd $(BRIDGE_BUILD_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- --with-linux=$(LINUX_DIR) \
- );
- touch $(BRIDGE_BUILD_DIR)/.configured
-
-$(BRIDGE_BUILD_DIR)/brctl/brctl: $(BRIDGE_BUILD_DIR)/.configured
- $(MAKE) -C $(BRIDGE_BUILD_DIR)
-
-$(TARGET_DIR)/$(BRIDGE_TARGET_BINARY): $(BRIDGE_BUILD_DIR)/brctl/brctl
- cp -af $(BRIDGE_BUILD_DIR)/brctl/brctl $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
- $(STRIP) $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
- #cp -af $(BRIDGE_BUILD_DIR)/brctl/brctld $(TARGET_DIR)/usr/sbin/
- #$(STRIP) $(TARGET_DIR)/usr/sbin/brctld
-
-bridge: linux $(TARGET_DIR)/$(BRIDGE_TARGET_BINARY)
-
-bridge-source: $(DL_DIR)/$(BRIDGE_SOURCE)
-
-bridge-clean:
- #$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BRIDGE_BUILD_DIR) uninstall
- -$(MAKE) -C $(BRIDGE_BUILD_DIR) clean
-
-bridge-dirclean:
- rm -rf $(BRIDGE_BUILD_DIR)