summaryrefslogtreecommitdiff
path: root/make/gcc-3.3.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-12 09:31:12 +0000
commit0fee9e90c2ea3accfaa521a303c6568ebf7baccc (patch)
tree2d18515f482954fb771dc19671c9056511f71127 /make/gcc-3.3.mk
parente150f3921b20b1b35a42d0b34067773814675d8a (diff)
Thomas Cameron writes:
this patch fixes the source file downloads when executing a "make source", and a few cut-and-paste (tm) errors in the *.mk files. Again, this is a patch against the current CVS sources, and includes my previous patch.
Diffstat (limited to 'make/gcc-3.3.mk')
-rw-r--r--make/gcc-3.3.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/make/gcc-3.3.mk b/make/gcc-3.3.mk
index 65fe4f9d9..d145bdd3f 100644
--- a/make/gcc-3.3.mk
+++ b/make/gcc-3.3.mk
@@ -56,6 +56,7 @@ endif
#
#############################################################
GCC_BUILD_DIR1:=$(TOOL_BUILD_DIR)/gcc-3.3-initial
+
$(DL_DIR)/$(GCC_SOURCE):
$(WGET) -P $(DL_DIR) $(GCC_SITE)/$(GCC_SOURCE)
@@ -305,6 +306,8 @@ endif
gcc3_3: binutils uclibc-configured gcc3_3_initial $(LIBFLOAT_TARGET) uclibc \
$(GCC_BUILD_DIR2)/.installed $(GCC_TARGETS)
+gcc3_3-source: $(DL_DIR)/$(GCC_SOURCE)
+
gcc3_3-clean:
rm -rf $(GCC_BUILD_DIR2)
rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)*