summaryrefslogtreecommitdiff
path: root/make/gcc-3.3.mk
diff options
context:
space:
mode:
authorManuel Novoa III <mjn3@codepoet.org>2003-11-24 20:50:12 +0000
committerManuel Novoa III <mjn3@codepoet.org>2003-11-24 20:50:12 +0000
commit196f87ce84b7e6140c34d930ba39b51313808e3a (patch)
tree1fae0e8e88c6ed048677477044e98eb33890486b /make/gcc-3.3.mk
parent3c79729137ec7b1f86470ee3bec163b848f06127 (diff)
Fix the condition for applying the i386 soft float patch.
Diffstat (limited to 'make/gcc-3.3.mk')
-rw-r--r--make/gcc-3.3.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make/gcc-3.3.mk b/make/gcc-3.3.mk
index a129bd875..0a12d043c 100644
--- a/make/gcc-3.3.mk
+++ b/make/gcc-3.3.mk
@@ -67,7 +67,7 @@ $(GCC_DIR)/.unpacked: $(DL_DIR)/$(GCC_SOURCE)
$(GCC_DIR)/.patched: $(GCC_DIR)/.unpacked
# Apply any files named gcc-*.patch from the source directory to gcc
$(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) gcc-*.patch
-ifneq ("$(strip $(TARGET_SOFT_FLOAT))","")
+ifeq ($(SOFT_FLOAT),true)
ifeq ("$(strip $(ARCH))","i386")
$(SOURCE_DIR)/patch-kernel.sh $(GCC_DIR) $(SOURCE_DIR) i386-gcc-soft-float.patch
endif