summaryrefslogtreecommitdiff
path: root/make/ncurses.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-02 08:43:57 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-02 08:43:57 +0000
commite8b26df50884dc3c434d91a40bb42c8edbbb0780 (patch)
tree91a87c8a369edb321a2424e8b47e26838cd8bc10 /make/ncurses.mk
parented90513d09af823e98efeb00c9e9b5228206cf63 (diff)
Update ncurses so it cross compiles properly
-Erik
Diffstat (limited to 'make/ncurses.mk')
-rw-r--r--make/ncurses.mk37
1 files changed, 19 insertions, 18 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index f8a90ad08..b021b30e0 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.9 2002/11/20 23:16:08 andersen Exp $
+# $Id: ncurses.mk,v 1.10 2003/01/02 08:43:57 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -38,33 +38,34 @@ $(NCURSES_DIR)/.dist: $(DL_DIR)/$(NCURSES_SOURCE)
touch $(NCURSES_DIR)/.dist
$(NCURSES_DIR)/.configured: $(NCURSES_DIR)/.dist
- (cd $(NCURSES_DIR); rm -rf config.cache; PATH=$(TARGET_PATH) \
- ./configure --prefix=/usr --with-shared --target=$(ARCH)-linux \
- --without-cxx --without-cxx-binding --without-ada \
+ (cd $(NCURSES_DIR); rm -rf config.cache; \
+ BUILD_CC=$(HOSTCC) HOSTCC=$(HOSTCC) CC=$(TARGET_CC1) \
+ ./configure --target=$(GNU_TARGET_NAME) --prefix=$(STAGING_DIR) \
+ --with-shared --without-cxx --without-cxx-binding --without-ada \
--without-progs --exec_prefix=$(STAGING_DIR)/usr/bin \
--libdir=$(STAGING_DIR)/lib --includedir=$(STAGING_DIR)/include \
--disable-nls);
touch $(NCURSES_DIR)/.configured
$(NCURSES_DIR)/lib/libncurses.so: $(NCURSES_DIR)/.configured
- make CC=$(TARGET_CC) LD=$(TARGET_LD) AS=$(TARGET_AS) \
- DESTDIR=$(STAGING_DIR) BUILD_CC=/usr/bin/gcc -C $(NCURSES_DIR)
+ $(MAKE) CC=$(TARGET_CC1) HOSTCC=$(HOSTCC) \
+ DESTDIR=$(STAGING_DIR) -C $(NCURSES_DIR)
$(STAGING_DIR)/lib/libncurses.so: $(NCURSES_DIR)/lib/libncurses.so
- cp -a $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
- cp -a $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
- cp -a $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(STAGING_DIR)/lib/
+ cp -dpf $(NCURSES_DIR)/include/curses.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/eti.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/form.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/menu.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/panel.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/term.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/termcap.h $(STAGING_DIR)/include/
+ cp -dpf $(NCURSES_DIR)/include/unctrl.h $(STAGING_DIR)/include/
(cd $(STAGING_DIR)/include; ln -fs curses.h ncurses.h)
$(TARGET_DIR)/lib/libncurses.so: $(STAGING_DIR)/lib/libncurses.so
- cp -a $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
- -cp -a $(STAGING_DIR)/usr/lib/terminfo $(TARGET_DIR)/usr/lib/
+ cp -dpf $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
+ -cp -dpf $(STAGING_DIR)/usr/lib/terminfo $(TARGET_DIR)/usr/lib/
for i in x/xterm x/xterm-color x/xterm-xfree86 v/vt100 v/vt200 a/ansi l/linux; do \
cd $(STAGING_DIR)/usr/share/; \
tar -cf - terminfo/$${i} | \
@@ -75,7 +76,7 @@ ncurses-clean:
rm -f $(STAGING_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/libncurses.so*
rm -f $(STAGING_DIR)/usr/share/tabset $(TARGET_DIR)/usr/share/tabset
rm -rf $(STAGING_DIR)/usr/share/terminfo $(TARGET_DIR)/usr/share/terminfo
- -make -C $(NCURSES_DIR) clean
+ -$(MAKE) -C $(NCURSES_DIR) clean
ncurses-dirclean:
rm -rf $(NCURSES_DIR)