summaryrefslogtreecommitdiff
path: root/make/netkittelnet.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-13 06:02:20 +0000
commit620dd7c5fd1895001a2c680d5dd1dbdbb6f3101d (patch)
treeaa08afb7d58fabed8f365bf373751992b792680c /make/netkittelnet.mk
parent192bace39e7c0fe5c4ccf9add25b67cb37f8abdc (diff)
By popular demand, use 'sed' rather than 'perl' for doing
search and replace stuff. Hopefully we do not have any perl specific regexs that will be broken by this change, but it seems to be working thus far anyways,
Diffstat (limited to 'make/netkittelnet.mk')
-rw-r--r--make/netkittelnet.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/make/netkittelnet.mk b/make/netkittelnet.mk
index ab4a2cb26..6b4b129da 100644
--- a/make/netkittelnet.mk
+++ b/make/netkittelnet.mk
@@ -19,9 +19,9 @@ netkittelnet-source: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_DIR)/.unpacked: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_CAT) $(DL_DIR)/$(NETKITTELNET_SOURCE) | tar -C $(BUILD_DIR) -xvf -
# use ANSI syntax
- perl -i -p -e "s/main\(\)/main(void)/;" $(NETKITTELNET_DIR)/configure
+ sed -ie "s/main\(\)/main(void)/;" $(NETKITTELNET_DIR)/configure
# Disable termcap support
- perl -i -p -e "s~(.*termcap\.h.*)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
+ sed -ie "s~(.*termcap\.h.*)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
# don't try to run cross compiled binaries while configuring things
cat $(NETKITTELNET_PATCH) | patch -p1 -d $(NETKITTELNET_DIR)
touch $(NETKITTELNET_DIR)/.unpacked
@@ -42,7 +42,7 @@ $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY): $(NETKITTELNET_DIR)/$(NETKITTELNET_
rm -f $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
cp $(NETKITTELNET_DIR)/$(NETKITTELNET_BINARY) $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
# Enable telnet in inetd
- perl -i -p -e "s~^#telnet.*~telnet\tstream\ttcp\tnowait\troot\t/usr/sbin/telnetd\t/usr/sbin/telnetd~;" $(TARGET_DIR)/etc/inetd.conf
+ sed -ie "s~^#telnet.*~telnet\tstream\ttcp\tnowait\troot\t/usr/sbin/telnetd\t/usr/sbin/telnetd~;" $(TARGET_DIR)/etc/inetd.conf
#$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(NETKITTELNET_DIR) install
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc