summaryrefslogtreecommitdiff
path: root/make/netkittelnet.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-11-18 17:56:52 +0000
committerEric Andersen <andersen@codepoet.org>2003-11-18 17:56:52 +0000
commit84c90117669a5e574a5c80073a6a6ce0e7a6b21f (patch)
tree34c0f305bffb64765dc4eefd5e2b8fc166703869 /make/netkittelnet.mk
parent6b4ce4ee0dee13ebabfbb585466af7ed1fad49bf (diff)
Fix some more perl -> sed conversion problems
Diffstat (limited to 'make/netkittelnet.mk')
-rw-r--r--make/netkittelnet.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/make/netkittelnet.mk b/make/netkittelnet.mk
index 64af06407..b59f29fc9 100644
--- a/make/netkittelnet.mk
+++ b/make/netkittelnet.mk
@@ -19,9 +19,9 @@ netkittelnet-source: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_DIR)/.unpacked: $(DL_DIR)/$(NETKITTELNET_SOURCE)
$(NETKITTELNET_CAT) $(DL_DIR)/$(NETKITTELNET_SOURCE) | tar -C $(BUILD_DIR) -xvf -
# use ANSI syntax
- sed -i -e "s/main\(\)/main(void)/;" $(NETKITTELNET_DIR)/configure
+ sed -i -e "s/main()/main(void)/;" $(NETKITTELNET_DIR)/configure
# Disable termcap support
- sed -i -e "s~(.*termcap\.h.*)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
+ sed -i -e "s~\(.*termcap\.h.*\)~/* \1 */~;" $(NETKITTELNET_DIR)/telnetd/telnetd.c
# don't try to run cross compiled binaries while configuring things
cat $(NETKITTELNET_PATCH) | patch -p1 -d $(NETKITTELNET_DIR)
touch $(NETKITTELNET_DIR)/.unpacked
@@ -47,7 +47,7 @@ $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY): $(NETKITTELNET_DIR)/$(NETKITTELNET_
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
-netkittelnet: uclibc $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
+netkittelnet: uclibc netkitbase $(TARGET_DIR)/$(NETKITTELNET_TARGET_BINARY)
netkittelnet-clean:
#$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(NETKITTELNET_DIR) uninstall