summaryrefslogtreecommitdiff
path: root/make/pppd.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-18 21:27:22 +0000
commit7129da009cc72575a84a30c4587bd99f745c49d4 (patch)
tree5c16654726d0b4c230ed957f88fd1b26be805171 /make/pppd.mk
parentf7070772fa2fef125169853747ff9aecc4a88962 (diff)
Merge a bunch of stuff over from the tuxscreen buildroot, with
many updates to make things be more consistant. -Erik
Diffstat (limited to 'make/pppd.mk')
-rw-r--r--make/pppd.mk66
1 files changed, 66 insertions, 0 deletions
diff --git a/make/pppd.mk b/make/pppd.mk
new file mode 100644
index 000000000..89eba4501
--- /dev/null
+++ b/make/pppd.mk
@@ -0,0 +1,66 @@
+#############################################################
+#
+# pppd
+#
+#############################################################
+PPPD_SOURCE:=ppp-2.4.1b2.tar.gz
+PPPD_SITE:=ftp://ftp.samba.org/pub/ppp
+PPPD_DIR:=$(BUILD_DIR)/ppp-2.4.1b2
+PPPD_CAT:=zcat
+PPPD_BINARY:=pppd/pppd
+PPPD_TARGET_BINARY:=usr/sbin/pppd
+
+
+$(DL_DIR)/$(PPPD_SOURCE):
+ $(WGET) -P $(DL_DIR) $(PPPD_SITE)/$(PPPD_SOURCE)
+
+pppd-source: $(DL_DIR)/$(PPPD_SOURCE)
+
+$(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
+ $(PPPD_CAT) $(DL_DIR)/$(PPPD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ perl -i -p -e 's/ -DIPX_CHANGE -DHAVE_MULTILINK -DHAVE_MMAP//' $(PPPD_DIR)/pppd/Makefile.linux
+ perl -i -p -e 's/$(INSTALL) -s/$(INSTALL)/' $(PPPD_DIR)/*/Makefile.linux
+ perl -i -p -e 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
+ perl -i -p -e 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
+ touch $(PPPD_DIR)/.unpacked
+
+$(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
+ (cd $(PPPD_DIR); rm -rf config.cache; \
+ PATH=$(STAGING_DIR)/bin:$$PATH CC=$(TARGET_CC1) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-nls \
+ );
+ touch $(PPPD_DIR)/.configured
+
+$(PPPD_DIR)/$(PPPD_BINARY): $(PPPD_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC1) -C $(PPPD_DIR)
+
+$(TARGET_DIR)/$(PPPD_TARGET_BINARY): $(PPPD_DIR)/$(PPPD_BINARY)
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(PPPD_DIR) install
+ rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
+ $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
+
+pppd: uclibc $(TARGET_DIR)/$(PPPD_TARGET_BINARY)
+
+pppd-clean:
+ rm -f $(TARGET_DIR)/usr/sbin/pppd
+ rm -f $(TARGET_DIR)/usr/sbin/chat
+ rm -rf $(TARGET_DIR)/etc/ppp
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC1) -C $(PPPD_DIR) uninstall
+ -$(MAKE) -C $(PPPD_DIR) clean
+
+pppd-dirclean:
+ rm -rf $(PPPD_DIR)
+
+