summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-06-04 21:39:44 +0000
committerEric Andersen <andersen@codepoet.org>2003-06-04 21:39:44 +0000
commitabcac7f79bc1e587ac683a08d4fb16ba070c1b7b (patch)
tree5e827164228be91e83468032e0022dfd01eb5b57 /make/uclibc_toolchain.mk
parent14b1c7d4f774fd725cfad8ea39b0f69b99021c68 (diff)
Fixup a case where system libs could sneak into the link process
due to collect2 making wrong assumptions.
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 2341bd8d9..663c21eb7 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -235,6 +235,13 @@ $(GCC_DIR)/.gcc_build_hacks: $(GCC_DIR)/.patched
perl -i -p -e "s,^#define.*STANDARD_INCLUDE_DIR.*,#define STANDARD_INCLUDE_DIR \
\"$(STAGING_DIR)/include\",;" $(GCC_DIR)/gcc/cppdefault.h;
#
+ # Prevent system glibc libraries from being found by collect2
+ # when it calls locatelib() and rummages about the system looking
+ # for libraries with the correct name...
+ #
+ perl -i -p -e "s,\"/lib/,\"$(STAGING_DIR)/lib,g;" $(GCC_DIR)/gcc/collect2.c
+ perl -i -p -e "s,\"/usr/,\"$(STAGING_DIR)/usr/,g;" $(GCC_DIR)/gcc/collect2.c
+ #
# Prevent gcc from using the unwind-dw2-fde-glibc code
#
perl -i -p -e "s,^#ifndef inhibit_libc,#define inhibit_libc\n\