summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-11-21 05:17:40 +0000
committerEric Andersen <andersen@codepoet.org>2002-11-21 05:17:40 +0000
commitb2a0d2216648564a815896756588a2d94610181e (patch)
tree23901e3d6476383fa90dd042e387f6cb7c079f05 /make/uclibc_toolchain.mk
parentdc77b4789dff32927dc4b39f23bb06bb5c02c135 (diff)
Fixup g++ to prevent gcc_target having a missing
dl_iterate_phdr symbol. Add a target 'cc' link to gcc. -Erik
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 2dc6833f0..36a9d3dfb 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -326,6 +326,9 @@ $(GCC_DIR)/.ldso_hacks: $(GCC_DIR)/.patched
$(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/
cp $(GCC_DIR)/libstdc++-v3/config/os/generic/bits/ctype_noninline.h \
$(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/
+ # Prevent gcc from using the unwind-dw2-fde-glibc code
+ perl -i -p -e "s,^#ifndef inhibit_libc,#define inhibit_libc\n#ifndef inhibit_libc,g;" \
+ $(GCC_DIR)/gcc/unwind-dw2-fde-glibc.c;
touch $(GCC_DIR)/.ldso_hacks
$(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.ldso_hacks