summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-01-08 18:17:28 +0000
committerEric Andersen <andersen@codepoet.org>2003-01-08 18:17:28 +0000
commite402401ff86a938725cf82d584d417d447ee1063 (patch)
tree684565501e894dab770469e32b0f94e8fe862598 /make/uclibc_toolchain.mk
parent3597007db3fc80a9d9b567a4e4d39fafdd867e72 (diff)
Fixup ncurses terminfo-dir. Fixup the ncurses-headers
zlib-headers openssl-headers targets. Modularize the enable-multilib settings -Erik
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index afb61633a..7e37cf387 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -28,6 +28,9 @@ GNU_TARGET_NAME:=$(ARCH)-linux
TARGET_LANGUAGES:=c,c++
MAKE=make
+# If you want multilib enabled, enable this...
+#MULTILIB:=--enable-multilib
+
#############################################################
#
# Where we can find things....
@@ -133,7 +136,7 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
--datadir=$(STAGING_DIR)/share --includedir=$(STAGING_DIR)/include \
--libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
--mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
- --enable-targets=$(GNU_TARGET_NAME) --enable-multilib \
+ --enable-targets=$(GNU_TARGET_NAME) $(MULTILIB) \
--program-prefix=$(ARCH)-uclibc-);
touch $(BINUTILS_DIR1)/.configured
@@ -222,7 +225,7 @@ $(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.gcc_build_hacks
--libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
--mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
--with-local-prefix=$(STAGING_DIR)/usr/local \
- --oldincludedir=$(STAGING_DIR)/usr/include --enable-multilib \
+ --oldincludedir=$(STAGING_DIR)/usr/include $(MULTILIB) \
--enable-target-optspace --disable-nls --with-gnu-ld \
--disable-shared --enable-languages=c --disable-__cxa_atexit \
--program-prefix=$(ARCH)-uclibc-);
@@ -365,7 +368,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_DIR)/.g++_build_hacks
--libdir=$(STAGING_DIR)/lib --localstatedir=$(STAGING_DIR)/var \
--mandir=$(STAGING_DIR)/man --infodir=$(STAGING_DIR)/info \
--with-local-prefix=$(STAGING_DIR)/usr/local \
- --oldincludedir=$(STAGING_DIR)/usr/include --enable-multilib \
+ --oldincludedir=$(STAGING_DIR)/usr/include $(MULTILIB) \
--enable-target-optspace --disable-nls --with-gnu-ld \
--disable-shared --enable-languages=$(TARGET_LANGUAGES) --disable-__cxa_atexit \
--program-prefix=$(ARCH)-uclibc-);