summaryrefslogtreecommitdiff
path: root/make/uclibc_toolchain.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2002-07-31 20:05:44 +0000
committerEric Andersen <andersen@codepoet.org>2002-07-31 20:05:44 +0000
commitfc5ce36326d0a5f4f67dea2c471baeaa48b0b079 (patch)
tree54393a4881f63a7d77a55a41d1a79b9904b5cef0 /make/uclibc_toolchain.mk
parent8e4e9eb65c74bafb9b3e93717c2200aafc536c7d (diff)
Fix logf/log support when doing C++
Diffstat (limited to 'make/uclibc_toolchain.mk')
-rw-r--r--make/uclibc_toolchain.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/make/uclibc_toolchain.mk b/make/uclibc_toolchain.mk
index 7bd6f46de..db2ee7096 100644
--- a/make/uclibc_toolchain.mk
+++ b/make/uclibc_toolchain.mk
@@ -386,6 +386,9 @@ $(GCC_DIR)/.ldso_hacks: $(GCC_DIR)/.patched
$(GCC_DIR)/libstdc++-v3/src/Makefile.am $(GCC_DIR)/libstdc++-v3/src/Makefile.in;
perl -i -p -e "s,3\.0\.0,9.9.0,g;" $(GCC_DIR)/libstdc++-v3/acinclude.m4 \
$(GCC_DIR)/libstdc++-v3/aclocal.m4 $(GCC_DIR)/libstdc++-v3/configure;
+ # Disable logf() -- we just use log() in uClibc
+ -perl -i -p -e "s,_GLIBCPP_HAVE_LOGF,0,g;" $(GCC_DIR)/libstdc++-v3/include/c_std/std_cmath.h \
+ $(GCC_DIR)/libstdc++-v3/include/c_shadow/bits/std_cmath.h
# For now, we don't support locale-ified ctype, so bypass that problem here
cp $(GCC_DIR)/libstdc++-v3/config/os/generic/bits/ctype_base.h \
$(GCC_DIR)/libstdc++-v3/config/os/gnu-linux/bits/