summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-09-17 14:16:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-17 14:16:42 +0200
commit16d6e9b3420e78a89960b8b68202ea46a618810d (patch)
tree155bcafed2fc72bb1ffcb7f4ac9c1c5c204efdae /package/Makefile.autotools.in
parentcbdb0a09224400c97632fa58e1a33d5901ff8f69 (diff)
Makefile.autotools.in: fix autoreconf libtool patching after libtool move
Commit 20f8a7dec6fc (support: move libtool patches in support/libtool) missed the autoreconf variant of the libtool patching, breaking the build for packages needing both autoreconf and libtool patching. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 13947873a..4cd63a36e 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -190,11 +190,11 @@ define AUTORECONF_HOOK
for i in `find $$($$(PKG)_SRCDIR) -name ltmain.sh`; do \
ltmain_version=`sed -n '/^[ ]*VERSION=/{s/^[ ]*VERSION=//;p;q;}' $$$$i | sed 's/\([0-9].[0-9]*\).*/\1/'`; \
if test $$$${ltmain_version} = "1.5"; then \
- support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v1.5.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v1.5.patch; \
elif test $$$${ltmain_version} = "2.2"; then\
- support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v2.2.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v2.2.patch; \
elif test $$$${ltmain_version} = "2.4"; then\
- support/scripts/apply-patches.sh $$$${i%/*} package buildroot-libtool-v2.4.patch; \
+ support/scripts/apply-patches.sh $$$${i%/*} support/libtool buildroot-libtool-v2.4.patch; \
fi \
done \
fi