summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-03-28 10:40:28 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-03-28 10:40:28 +0000
commit3d3775e3cd5ff4e2a09ec1bb826c41925801a257 (patch)
tree55d9860d3b337822e22e9e53acdd68cfa115bcc1 /package/Makefile.autotools.in
parenta7c3ddc4e0718ba4edda29d14dd391075287ca64 (diff)
AUTOTARGETS: also support non-version-dependent arch specific patches
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index cffa20483..1243c3522 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -158,9 +158,9 @@ $(BUILD_DIR)/%/.stamp_patched:
if test "$(wildcard $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER)*.patch*)"; then \
toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME) $(NAMEVER)\*.patch $(NAMEVER)\*.patch.$(ARCH) || exit 1; \
else \
- toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME) $($(PKG)_NAME)\*.patch || exit 1; \
+ toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME) $($(PKG)_NAME)\*.patch $($(PKG)_NAME)\*.patch.$(ARCH) || exit 1; \
if test -d package/$($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER); then \
- toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER) \*.patch || exit 1; \
+ toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER) \*.patch \*.patch.$(ARCH) || exit 1; \
fi; \
fi; \
fi; \