summaryrefslogtreecommitdiff
path: root/package/Makefile.autotools.in
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-05-01 14:07:11 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-05-01 14:07:11 +0000
commitf11fa22d0e88c5a3b04429a3110a3cbbf0c30c49 (patch)
treef151f94d270cf31a0b8d4aefd96e124477f63cbe /package/Makefile.autotools.in
parentac6ab6a2545de81916bb1bd8aeecaf773292de5b (diff)
remove unnecessary libdir-la.patch patches and modify Makefile.autotools.in to patch libtool automatically.
Diffstat (limited to 'package/Makefile.autotools.in')
-rw-r--r--package/Makefile.autotools.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 492d4497d..cf2ac7d23 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -142,7 +142,12 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(Q)mkdir -p $(@D)
$(Q)$(INFLATE$(suffix $($(PKG)_SOURCE))) $(DL_DIR)/$($(PKG)_SOURCE) | \
$(TAR) --strip-components=1 -C $(@D) $(TAR_OPTIONS) -
- chmod -R ug+rw $(@D)
+# some packages have messed up permissions inside
+ $(Q)chmod -R ug+rw $(@D)
+# if the package uses libtool, patch it for cross-compiling in buildroot
+ for i in `find $(@D) -name ltmain.sh`; do \
+ toolchain/patch-kernel.sh $${i%/*} package buildroot-libtool.patch; \
+ done
$(Q)touch $@
# Patch
@@ -185,6 +190,9 @@ $(BUILD_DIR)/%/.stamp_configured:
$(call MESSAGE,"Configuring")
$(Q)if test "$($(PKG)_AUTORECONF)" = "YES"; then \
cd $(@D)/$($(PKG)_SUBDIR) && $(AUTORECONF); \
+ for i in `find $(@D)/$($(PKG)_SUBDIR) -name ltmain.sh`; do \
+ ../../toolchain/patch-kernel.sh $${i%/*} ../../package buildroot-libtool.patch; \
+ done \
fi
cd $(@D)/$($(PKG)_SUBDIR) && rm -f config.cache && \
$(TARGET_CONFIGURE_OPTS) \